aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Joldasov <bratishkaerik@landless-city.net>2024-08-01 00:58:48 +0500
committerEric Joldasov <bratishkaerik@landless-city.net>2024-08-01 00:58:55 +0500
commitf4e89c5a87714b8ad2bddb1388719857a607c134 (patch)
tree66cb9cab3a9aa9b9240950485e42c2318169d092 /net-p2p
parentnet-im/chatterino: ebuild syntax fixup (diff)
downloadguru-f4e89c5a87714b8ad2bddb1388719857a607c134.tar.gz
guru-f4e89c5a87714b8ad2bddb1388719857a607c134.tar.bz2
guru-f4e89c5a87714b8ad2bddb1388719857a607c134.zip
net-p2p/yggdrasil-go: add 0.5.6
Signed-off-by: Eric Joldasov <bratishkaerik@landless-city.net>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/yggdrasil-go/Manifest2
-rw-r--r--net-p2p/yggdrasil-go/yggdrasil-go-0.5.6.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/net-p2p/yggdrasil-go/Manifest b/net-p2p/yggdrasil-go/Manifest
index a7e45d23a9..2bafeb9369 100644
--- a/net-p2p/yggdrasil-go/Manifest
+++ b/net-p2p/yggdrasil-go/Manifest
@@ -1,2 +1,4 @@
DIST yggdrasil-go-0.5.5-vendor.tar.xz 1443888 BLAKE2B 712bcb42a38b10c950ac8c6ce9301dbbaf4a77026bcc2c6d78321c7423ef3dc0fcba5bf94c0cd674af3e911eda476ae8c7d7bb7c782328c5201e91efe2958d1d SHA512 10be1cd6dd5b4fb11b70c48e9cdeb26f4534424dbb0dcd93d0a3d8de3b63d0849dcc55b3394ba3ab74c19e15592d26c2be7e9f4e89a8dccb6c17da572907b5ba
DIST yggdrasil-go-0.5.5.tar.gz 105482 BLAKE2B 7afbde70e2aec71f47ba32730611d22b87fa23ff4d488a33ca82124cb4ec211c654e780b3c8c703100eb065c05c54561ca36136765050c96e297f30a5656bc61 SHA512 13ee5c719335d7a599019d004cd8d82883c7a2beb707de968a0934982364a0f70982f14157bd9aaabda9595f194594901a9158cfeb272491a71b5392abd79dc4
+DIST yggdrasil-go-0.5.6-vendor.tar.xz 1434944 BLAKE2B 7abeea0b8a50ec2d2a9dd99842e50912d0e9d4f327dbf5c66c69d2848d219264bef068183e5e80e400f3b187d733cbe708fbc3493f27af1e1922a078f31e1202 SHA512 de555d765155f20e47c742b5dba330ab2659c0a414cbe6c7a3103328f21c8d6a45bb35755c9a1b7c190d4c0aeb2495ca8e1f0ea350b55bec7de405f7b35ecc86
+DIST yggdrasil-go-0.5.6.tar.gz 106181 BLAKE2B 01302cb2a4e08f84bcc33b01e86315a948d0bf6900c2e592edc6cc618ef8d09ea20793ea41ae1ed61ef094a9266a2ff3df840a8ca59c0ba496a03519b8869497 SHA512 1c6f8767000a41d4b4f62c3e6df1e562289b3e699542a2fa99781b74eed2eda7e3c5968f50d068360d72b9308e8e27dfd14f42fd7ff2c63982dd48cc5afd85c2
diff --git a/net-p2p/yggdrasil-go/yggdrasil-go-0.5.6.ebuild b/net-p2p/yggdrasil-go/yggdrasil-go-0.5.6.ebuild
new file mode 100644
index 0000000000..9b6af0f473
--- /dev/null
+++ b/net-p2p/yggdrasil-go/yggdrasil-go-0.5.6.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps go-module linux-info systemd
+
+DESCRIPTION="An experiment in scalable routing as an encrypted IPv6 overlay network"
+HOMEPAGE="https://yggdrasil-network.github.io/"
+SRC_URI="
+ https://github.com/yggdrasil-network/yggdrasil-go/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://codeberg.org/BratishkaErik/distfiles/releases/download/yggdrasil-go-${PV}/yggdrasil-go-${PV}-vendor.tar.xz
+"
+
+LICENSE="LGPL-3 MIT Apache-2.0 BSD ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+RESTRICT="mirror"
+
+DEPEND="
+ acct-user/yggdrasil
+ acct-group/yggdrasil
+"
+
+BDEPEND=">=dev-lang/go-1.21"
+
+DOCS=( README.md CHANGELOG.md )
+
+FILECAPS=(
+ cap_net_admin,cap_net_bind_service "usr/bin/yggdrasil"
+)
+
+CONFIG_CHECK="~TUN"
+ERROR_TUN="Your kernel lacks TUN support."
+
+src_compile() {
+ local ver_config="github.com/yggdrasil-network/yggdrasil-go/src/version"
+
+ local version_disable_detect_flags="-X ${ver_config}.buildName=${PN}"
+ version_disable_detect_flags+=" -X ${ver_config}.buildVersion=v${PV}"
+
+ GOFLAGS+=" -mod=vendor -trimpath"
+
+ local GO_LDFLAGS
+ GO_LDFLAGS="-s -linkmode external -extldflags \"${LDFLAGS}\" ${version_disable_detect_flags}"
+
+ local cmd
+ for cmd in yggdrasil{,ctl}; do
+ ego build ${GOFLAGS} "-ldflags=${GO_LDFLAGS}" ./cmd/"${cmd}"
+ done
+}
+
+src_install() {
+ dobin yggdrasil{,ctl}
+ einstalldocs
+
+ systemd_dounit "contrib/systemd/yggdrasil.service"
+ systemd_dounit "contrib/systemd/yggdrasil-default-config.service"
+ doinitd "contrib/openrc/yggdrasil"
+}