aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-01-22 03:45:52 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-01-22 03:50:05 +0500
commit89e6e1e426e30a1eefae39c053aa53e574661c23 (patch)
treef0c01153b86eec8c44c5f0cb6a7daa7109a33a2a /sci-misc
parentdev-python/types-urllib3: treeclean (diff)
downloadguru-89e6e1e426e30a1eefae39c053aa53e574661c23.tar.gz
guru-89e6e1e426e30a1eefae39c053aa53e574661c23.tar.bz2
guru-89e6e1e426e30a1eefae39c053aa53e574661c23.zip
sci-misc/boinc-wrapper: remove weird syntax sugar
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc-wrapper/boinc-wrapper-26018-r1.ebuild (renamed from sci-misc/boinc-wrapper/boinc-wrapper-26018.ebuild)25
1 files changed, 16 insertions, 9 deletions
diff --git a/sci-misc/boinc-wrapper/boinc-wrapper-26018.ebuild b/sci-misc/boinc-wrapper/boinc-wrapper-26018-r1.ebuild
index 473d5754fc..6142c048cf 100644
--- a/sci-misc/boinc-wrapper/boinc-wrapper-26018.ebuild
+++ b/sci-misc/boinc-wrapper/boinc-wrapper-26018-r1.ebuild
@@ -1,19 +1,20 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-BOINC_SUBMODULE="samples/wrapper"
-inherit boinc
+inherit autotools edo
DESCRIPTION="Wrapper to use non-BOINC apps with BOINC"
HOMEPAGE="https://boinc.berkeley.edu/trac/wiki/WrapperApp"
+SRC_URI="https://github.com/BOINC/boinc/archive/refs/tags/wrapper/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~x86"
LICENSE="Info-ZIP LGPL-3+ regexp-UofT"
SLOT="0"
# libboinc-api dependencies
+# no subslot, because "-Wl,--as-needed" removes them
DEPEND="
dev-libs/openssl
media-libs/freeglut
@@ -22,18 +23,24 @@ DEPEND="
DOCS=( job.xml )
-boinc_require_source ${PV} wrapper
-boinc_enable_autotools
+src_prepare() {
+ default
+ eautoreconf
+}
-src_compile() {
- pushd "${BOINC_BUILD_DIR}" || die
- emake
- popd || die
+src_configure() {
+ edo bash generate_svn_version.sh
+ econf --enable-static --enable-pkg-devel --disable-fcgi
+}
+src_compile() {
emake
+ emake -C samples/wrapper
}
src_install() {
+ cd samples/wrapper || die
+
einstalldocs
newbin wrapper boinc-wrapper
}