aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNRK <nrk@disroot.org>2023-05-15 18:46:20 +0600
committerNRK <nrk@disroot.org>2023-05-15 18:46:20 +0600
commit560cc96fdde4881b899b2d561614a87f6c0b811a (patch)
treebd425e6b17aa5aa0dc5f1a088afc8701c6a14805 /sys-devel
parentsys-cluster/pcs: treeclean broken pkg (diff)
downloadguru-560cc96fdde4881b899b2d561614a87f6c0b811a.tar.gz
guru-560cc96fdde4881b899b2d561614a87f6c0b811a.tar.bz2
guru-560cc96fdde4881b899b2d561614a87f6c0b811a.zip
sys-devel/gdb-dashboard: init new package
ebuild mostly inspired/stolen from pentoo, but a couple things have been changed to fit EAPI8 + some minor improvements (e.g using optfeature for optional syntax highlighting). Signed-off-by: NRK <nrk@disroot.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gdb-dashboard/Manifest1
-rw-r--r--sys-devel/gdb-dashboard/gdb-dashboard-0.17.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sys-devel/gdb-dashboard/Manifest b/sys-devel/gdb-dashboard/Manifest
new file mode 100644
index 000000000..b38215757
--- /dev/null
+++ b/sys-devel/gdb-dashboard/Manifest
@@ -0,0 +1 @@
+DIST gdb-dashboard-0.17.2.tar.gz 23275 BLAKE2B 6c7cfd2ac5ffa686629bbfa628bfcf1b383e44d632c3acf1205a7e0e01192f167744e54f2e145644c1e2f8479f9021ca05a39481a4f4c07f0ca2db75946392cd SHA512 caa723479b8539f01e9c46e2c95731fed2fe16087d495aa9eddacf93ffbf5f61f59166a106157ea099e0e2d90d1d0e97b7d2b6b3addb776506ce809438871006
diff --git a/sys-devel/gdb-dashboard/gdb-dashboard-0.17.2.ebuild b/sys-devel/gdb-dashboard/gdb-dashboard-0.17.2.ebuild
new file mode 100644
index 000000000..e25cff86d
--- /dev/null
+++ b/sys-devel/gdb-dashboard/gdb-dashboard-0.17.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit python-single-r1 optfeature wrapper
+
+DESCRIPTION="Modular visual interface for GDB in Python"
+HOMEPAGE="https://github.com/cyrus-and/gdb-dashboard"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/cyrus-and/gdb-dashboard"
+else
+ SRC_URI="https://github.com/cyrus-and/gdb-dashboard/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="sys-devel/gdb[python]"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ newins .gdbinit "${PN}"
+
+ # install a convenient wrapper. disables any typical .gdbinit (-nh) to
+ # get a clean state without interference. -q to disable annoying
+ # copyright message at startup.
+ make_wrapper "$PN" "gdb -q -nh -iex 'source /usr/share/${PN}/${PN}'"
+
+ dodoc README.md
+}
+
+pkg_postinst() {
+ einfo "To use ${PN}:"
+ einfo " Either use the installed '${PN}' wrapper script directly."
+ einfo " Or put 'source /usr/share/${PN}/${PN}' in your .gdbinit file."
+ einfo ""
+
+ optfeature "syntax highlighting" "dev-python/pygments"
+}