aboutsummaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorVitaly Zdanevich <zdanevich.vitaly@ya.ru>2023-09-11 10:37:48 +0400
committerVitaly Zdanevich <zdanevich.vitaly@ya.ru>2023-09-11 10:37:48 +0400
commit4d7004fc93fc0fe3c5414b1a96e792c085f1451c (patch)
treec81b35d1118689e60d8829fc10cb6f39deb79f06 /sys-fs
parentwww-apps/forgejo: add 1.20.4.0, drop 1.20.2.0 (diff)
downloadguru-4d7004fc93fc0fe3c5414b1a96e792c085f1451c.tar.gz
guru-4d7004fc93fc0fe3c5414b1a96e792c085f1451c.tar.bz2
guru-4d7004fc93fc0fe3c5414b1a96e792c085f1451c.zip
sys-fs/mountpoint-s3-bin: new package, add 1.0.1
Signed-off-by: Vitaly Zdanevich <zdanevich.vitaly@ya.ru>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/mountpoint-s3-bin/Manifest1
-rw-r--r--sys-fs/mountpoint-s3-bin/metadata.xml28
-rw-r--r--sys-fs/mountpoint-s3-bin/mountpoint-s3-bin-1.0.1.ebuild21
3 files changed, 50 insertions, 0 deletions
diff --git a/sys-fs/mountpoint-s3-bin/Manifest b/sys-fs/mountpoint-s3-bin/Manifest
new file mode 100644
index 000000000..f1978fc90
--- /dev/null
+++ b/sys-fs/mountpoint-s3-bin/Manifest
@@ -0,0 +1 @@
+DIST mount-s3-1.0.1-x86_64.tar.gz 14139077 BLAKE2B 0cd32334cf893559253b26f71b06e996c0628bbc2bc0884cf897d72605944bed3b819554b93268547b364ad0f746c04b03bfba8f331ffb7209752aba54eff2bb SHA512 f5d2c2a79cea02d53000b63adaaa2efb05903d13ea4e5081beec50c2c24298ac598a275fcce8cf015a8e7245bf9b048d519e7313a88c653eba1b88137a59257f
diff --git a/sys-fs/mountpoint-s3-bin/metadata.xml b/sys-fs/mountpoint-s3-bin/metadata.xml
new file mode 100644
index 000000000..3f41b359a
--- /dev/null
+++ b/sys-fs/mountpoint-s3-bin/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Vitaly Zdanevich</name>
+ <email>zdanevich.vitaly@ya.ru</email>
+ </maintainer>
+ <longdescription lang="en">
+Mountpoint for Amazon S3 is a simple, high-throughput file client for mounting an Amazon S3 bucket as a local file system. With Mountpoint for Amazon S3, your applications can access objects stored in Amazon S3 through file operations like open and read. Mountpoint for Amazon S3 automatically translates these operations into S3 object API calls, giving your applications access to the elastic storage and throughput of Amazon S3 through a file interface.
+
+Mountpoint for Amazon S3 is optimized for applications that need high read throughput to large objects, potentially from many clients at once, and to write new objects sequentially from a single client at a time. This means it's a great fit for applications that use a file interface to:
+
+* read large objects from S3, potentially from many instances concurrently, without downloading them to local storage first
+* access only some S3 objects out of a larger data set, but can't predict which objects in advance
+* upload their output to S3 directly, or upload files from local storage with tools like cp
+
+but probably not the right fit for applications that:
+
+* use file operations that S3 doesn't natively support, like directory renaming or symlinks
+* make edits to existing files (don't work on your Git repository or run vim in Mountpoint 😄)
+
+Mountpoint for Amazon S3 does not implement all the features of a POSIX file system, and there are some differences that may affect compatibility with your application. See Mountpoint file system behavior for a detailed description of Mountpoint for Amazon S3's behavior and POSIX support and how they could affect your application.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">awslabs/mountpoint-s3</remote-id>
+ <bugs-to>https://github.com/awslabs/mountpoint-s3/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-fs/mountpoint-s3-bin/mountpoint-s3-bin-1.0.1.ebuild b/sys-fs/mountpoint-s3-bin/mountpoint-s3-bin-1.0.1.ebuild
new file mode 100644
index 000000000..05fd6dc76
--- /dev/null
+++ b/sys-fs/mountpoint-s3-bin/mountpoint-s3-bin-1.0.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Fuse for AWS S3 (Simple Storage Service), official"
+HOMEPAGE="https://github.com/awslabs/mountpoint-s3"
+
+SRC_URI="https://s3.amazonaws.com/mountpoint-s3-release/${PV}/x86_64/mount-s3-${PV}-x86_64.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="sys-fs/fuse:0"
+
+S="${WORKDIR}"
+
+src_install() {
+ newbin "${S}/bin/mount-s3" mount-s3-bin
+}