aboutsummaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-08-03 20:26:29 -0700
committerJohn M. Harris Jr. <johnmh@johnmh.me>2024-08-03 20:26:45 -0700
commitfb9e7ef63e934433e410a0497798d3b95a14b9b0 (patch)
tree9fb5b21d4d4dcd8861bf227a06dcdd7a5dcb7549 /sys-fs
parentsys-fs/sanoid: add 9999 (diff)
downloadguru-fb9e7ef63e934433e410a0497798d3b95a14b9b0.tar.gz
guru-fb9e7ef63e934433e410a0497798d3b95a14b9b0.tar.bz2
guru-fb9e7ef63e934433e410a0497798d3b95a14b9b0.zip
sys-fs/sanoid: add 2.2.0
Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/sanoid/Manifest1
-rw-r--r--sys-fs/sanoid/sanoid-2.2.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sys-fs/sanoid/Manifest b/sys-fs/sanoid/Manifest
new file mode 100644
index 000000000..45b38e66b
--- /dev/null
+++ b/sys-fs/sanoid/Manifest
@@ -0,0 +1 @@
+DIST sanoid-2.2.0.gh.tar.gz 77865 BLAKE2B 3183ed82b392730db403dea87c72aaa9303f35227739eda5d401bd6ebe7c149977e4edca0dfd10f34c2b02932b9a5145f880425462d1e9df9d45cebf13d962bd SHA512 293c31f2da80d698987c7f06314bf6e62a54011e4028b2aa8e70d482e7757bf8ae89efe7413b8f88072bac064710ca0756650e5b6f9827a5ff50a97fd72e86ad
diff --git a/sys-fs/sanoid/sanoid-2.2.0.ebuild b/sys-fs/sanoid/sanoid-2.2.0.ebuild
new file mode 100644
index 000000000..3a8a47483
--- /dev/null
+++ b/sys-fs/sanoid/sanoid-2.2.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Policy-driven snapshot management and replication tools for OpenZFS."
+HOMEPAGE="https://github.com/jimsalterjrs/sanoid"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jimsalterjrs/${PN^}.git"
+else
+ SRC_URI="https://github.com/jimsalterjrs/${PN^}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+IUSE="gzip lzop pigz zstd"
+BDEPEND="
+ dev-lang/perl
+ sys-apps/groff
+"
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Capture-Tiny
+ dev-perl/Config-IniFiles
+ sys-apps/pv
+ sys-block/mbuffer
+ sys-fs/zfs
+ virtual/perl-Data-Dumper
+ virtual/perl-Getopt-Long
+ virtual/ssh
+ gzip? ( app-arch/gzip )
+ lzop? ( app-arch/lzop )
+ pigz? ( app-arch/pigz )
+ zstd? ( app-arch/zstd )
+"
+
+src_compile() {
+ perldoc -onroff -dsanoid.1 sanoid || die "Failed to compile sanoid.1"
+ perldoc -onroff -dsyncoid.1 syncoid || die "Failed to compile syncoid.1"
+}
+
+src_install() {
+ dobin sanoid
+ dobin syncoid
+
+ doman sanoid.1 syncoid.1
+
+ insinto /etc/sanoid
+ doins "sanoid.defaults.conf"
+
+ elog "You will need to set up your /etc/sanoid/sanoid.conf file before"
+ elog "running sanoid for the first time. For details, please consult the"
+ elog "documentation on https://github.com/jimsalterjrs/sanoid."
+}