aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2020-05-18 18:51:44 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2020-05-18 18:58:01 +0300
commit3d4875121f487b3f2b197bed5bf3b062592cfb0c (patch)
tree324a483758a137ad548a640021d405c6529017da /x11-libs/gtk-fortran
parentdev-python/trueskill: python3.8 (diff)
downloadguru-3d4875121f487b3f2b197bed5bf3b062592cfb0c.tar.gz
guru-3d4875121f487b3f2b197bed5bf3b062592cfb0c.tar.bz2
guru-3d4875121f487b3f2b197bed5bf3b062592cfb0c.zip
x11-libs/gtk-fortran: 20.04 version bump
In this ebuild: - The "high-level" build option patch is dropped due to this is implemented in source code of this version; The disabling "sketch" build part is moved "sed" command call while patching "CMakeLists.txt" file. - The "doc" USE-flag is dropped as "doxygen" target was removed by upstream. Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
Diffstat (limited to 'x11-libs/gtk-fortran')
-rw-r--r--x11-libs/gtk-fortran/Manifest1
-rw-r--r--x11-libs/gtk-fortran/gtk-fortran-20.04.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/x11-libs/gtk-fortran/Manifest b/x11-libs/gtk-fortran/Manifest
index b52b03212..bf51ff021 100644
--- a/x11-libs/gtk-fortran/Manifest
+++ b/x11-libs/gtk-fortran/Manifest
@@ -1 +1,2 @@
DIST gtk-fortran-19.04.tar.gz 4164311 BLAKE2B 728d55890344894df534de1530135933e488ea197dc2d9b8f28571ce56a236e7fe2be23ebc4708e1ae5ffeb10e4ee584db366945e3d262225c4e9f7db4fa611d SHA512 58154df7c531ebfabcc687f8f38d3c7db7f7adb6cc015e1ce9c44455ab2506a4dfe6b073a88100131ac3712fee68844e4544f2f77d954285e3fbc86e1b3d9394
+DIST gtk-fortran-20.04.tar.gz 4066185 BLAKE2B 45a84dfd27b5f0495da55526262e3ba888f1d7eaa685336aaafae726dab63d047d71901a07eafc08c2f51d1e24a087e85f7b2a172323a8f1608c5ff64193f31c SHA512 b8ebf9e129c95c7aa2cf67d41f16915a18f05bd4cce4001ed56148b6d4e4ae3fe2b2e2080f35a1db4be8256bc3d5992061bf0c0e55e332f9a75a4a03e52cded5
diff --git a/x11-libs/gtk-fortran/gtk-fortran-20.04.ebuild b/x11-libs/gtk-fortran/gtk-fortran-20.04.ebuild
new file mode 100644
index 000000000..8bb1099e1
--- /dev/null
+++ b/x11-libs/gtk-fortran/gtk-fortran-20.04.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_MAKEFILE_GENERATOR="emake"
+FORTRAN_STANDARD=2003
+
+inherit cmake fortran-2
+
+DESCRIPTION="A GTK+ binding to build Graphical User Interfaces in Fortran"
+HOMEPAGE="https://github.com/vmagnin/gtk-fortran"
+SRC_URI="https://github.com/vmagnin/${PN}/archive/v${PV}.gtk3.24.18.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/${P}.gtk3.24.18"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="examples high-level plplot"
+REQUIRED_USE="plplot? ( high-level )"
+
+RDEPEND="
+ x11-libs/gtk+:3
+ plplot? ( >=sci-libs/plplot-5.13.0[cairo,fortran] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/fortran
+ virtual/pkgconfig
+"
+
+DOCS=( "README.md" "README-high-level.md" "CHANGELOG.md" )
+
+pkg_setup() {
+ fortran-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ # Fix library installation path and disable 'sketcher' build
+ sed -i -e "s:CMAKE_INSTALL_LIBDIR lib:CMAKE_INSTALL_LIBDIR $(get_libdir):" \
+ -e "s: add_subdirectory(sketcher)::" CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ mycmakeargs+=(
+ -DEXCLUDE_PLPLOT=$(usex plplot false true)
+ -DNO_BUILD_HL=$(usex high-level false true)
+ -DINSTALL_EXAMPLES=$(usex examples)
+ -DNO_BUILD_EXAMPLES=true
+ )
+ cmake_src_configure
+}