aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2023-09-12 16:34:07 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2023-09-12 16:34:07 +0300
commit1dcd4dd56aa63d4853bac37c288ae254bfee01f3 (patch)
tree5d923256bc8082a90beb81baadfd78f9e2f4d69a /x11-libs
parentdev-vcs/gitqlient: 1.6.2 version bump (replace 1.6.2_pre20230519) (diff)
downloadguru-1dcd4dd56aa63d4853bac37c288ae254bfee01f3.tar.gz
guru-1dcd4dd56aa63d4853bac37c288ae254bfee01f3.tar.bz2
guru-1dcd4dd56aa63d4853bac37c288ae254bfee01f3.zip
x11-libs/gtk-fortran: 4.4.1 version bump
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk-fortran/Manifest1
-rw-r--r--x11-libs/gtk-fortran/gtk-fortran-4.4.1.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/x11-libs/gtk-fortran/Manifest b/x11-libs/gtk-fortran/Manifest
index a0c1039429..dd71f485fc 100644
--- a/x11-libs/gtk-fortran/Manifest
+++ b/x11-libs/gtk-fortran/Manifest
@@ -1,3 +1,4 @@
DIST gtk-fortran-3.24.31.tar.gz 4287676 BLAKE2B 9fe3f83158ea504d492978ddd0b3a6d4aad5f5325df7c6ebbeb6d11ecb48d1097ee3c7b213c8824a5e4adb15da9af1da64c72b9089746dd0bb5d1d91dc76c766 SHA512 3d1a62837f4750b5c284a1548ede0ecfe8ad2f2619ca7ee2eb75e4cb7fcc739de90d67ff61d406b1f13fe0a2a9f1e23a1baa50afdc8caaaf1b3866e5640cb3f1
DIST gtk-fortran-4.3.0.tar.gz 4270611 BLAKE2B 6ba22a45864dda40b14ab443fd3025f320e887c5d00158d790b5fcb6c6f4c5c74dca2ad5d147f931d459ab610102222c5440e668f623fc6ec88a590ccb83ff32 SHA512 0bd957c02956f74452c52a5e0fe9eadda997b88241fa69e6ee50ef58bd0d6156d73c9db49ff4eef384ff9b9a7e1824cfb26016e4d912002a7f3f92c69508369c
DIST gtk-fortran-4.4.0.tar.gz 4442859 BLAKE2B de24779cc457d92fdcc5e7cc3e37dc3dd9f557b799e4186e6e03b1c39ce3520d3cc0896817810936644839491a9b0886ed77b60ba22cc30f1b31c4d66adcfe23 SHA512 c597875fe6163e82348b5464ad08fb11bfc9c4e64d04b49d47ccd9ef58ba0771db1ea201f1fc6265967b1689e29bc3bec1f089032b5111148ebe07a88a5f3c1b
+DIST gtk-fortran-4.4.1.tar.gz 4443829 BLAKE2B 23a03649943f30dcf25002168deb3e9b5be018574cba3bcff393d2439a9ca2aabb4c8461481d66280c9a6629c0b6d084e1bc8c18abf76b6a4340da9a6031ec7d SHA512 4ea107f3040536fe44d479045005dda96c51f0c7aebaf09153890a511947ef66979d7a61d37b6b9d1e743195b1d09c8b1e4ed3a33334001ac26c04453e15c345
diff --git a/x11-libs/gtk-fortran/gtk-fortran-4.4.1.ebuild b/x11-libs/gtk-fortran/gtk-fortran-4.4.1.ebuild
new file mode 100644
index 0000000000..7a016cdfc7
--- /dev/null
+++ b/x11-libs/gtk-fortran/gtk-fortran-4.4.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_MAKEFILE_GENERATOR="emake"
+FORTRAN_STANDARD=2003
+VIRTUALX_REQUIRED="test"
+
+inherit cmake fortran-2 virtualx
+
+DESCRIPTION="A GTK+ binding to build Graphical User Interfaces in Fortran"
+HOMEPAGE="https://github.com/vmagnin/gtk-fortran"
+SRC_URI="https://github.com/vmagnin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="examples high-level plplot static-libs test"
+REQUIRED_USE="plplot? ( high-level )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ gui-libs/gtk:4
+ plplot? ( >=sci-libs/plplot-5.15.0[cairo,fortran] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/fortran
+ virtual/pkgconfig
+"
+
+DOCS=( "README.md" "README-high-level.md" "CHANGELOG.md" )
+
+pkg_setup() {
+ fortran-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ # Fix library installation path, disable 'sketcher' build, pass LDFLAGS
+ sed -i -e "s:CMAKE_INSTALL_LIBDIR lib:CMAKE_INSTALL_LIBDIR $(get_libdir):" \
+ -e "s: add_subdirectory(sketcher)::" \
+ -e 's:"-rdynamic":"-rdynamic '"${LDFLAGS}"'":' CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ mycmakeargs+=(
+ -DEXCLUDE_PLPLOT=$(usex plplot false true)
+ -DNO_BUILD_HL=$(usex high-level false true)
+ -DINSTALL_EXAMPLES=$(usex examples)
+ -DNO_BUILD_EXAMPLES=true
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ virtx cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+
+ # Remove static library here as it's used to build additional tools
+ if use !static-libs ; then
+ rm "${ED}/usr/$(get_libdir)/libgtk-${SLOT}-fortran.a" || die
+ fi
+}