aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/kak-lsp/kak-lsp-15.0.1.ebuild')
-rw-r--r--app-editors/kak-lsp/kak-lsp-15.0.1.ebuild202
1 files changed, 202 insertions, 0 deletions
diff --git a/app-editors/kak-lsp/kak-lsp-15.0.1.ebuild b/app-editors/kak-lsp/kak-lsp-15.0.1.ebuild
new file mode 100644
index 000000000..a84e9c959
--- /dev/null
+++ b/app-editors/kak-lsp/kak-lsp-15.0.1.ebuild
@@ -0,0 +1,202 @@
+# Copyright 2001-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+ adler32@1.2.0
+ aho-corasick@1.1.2
+ android-tzdata@0.1.1
+ android_system_properties@0.1.5
+ arc-swap@1.6.0
+ atty@0.2.14
+ autocfg@1.1.0
+ bitflags@1.3.2
+ bitflags@2.4.1
+ bumpalo@3.14.0
+ cc@1.0.83
+ cfg-if@0.1.10
+ cfg-if@1.0.0
+ chrono@0.4.31
+ clap@3.2.25
+ clap_lex@0.2.4
+ core-foundation-sys@0.8.4
+ crc32fast@1.3.2
+ crossbeam-channel@0.5.8
+ crossbeam-utils@0.8.16
+ daemonize@0.5.0
+ deranged@0.3.9
+ diffs@0.4.1
+ dirs@2.0.2
+ dirs-next@2.0.0
+ dirs-sys@0.3.7
+ dirs-sys-next@0.1.2
+ either@1.9.0
+ enum_primitive@0.1.1
+ errno@0.3.5
+ field-offset@0.3.6
+ filetime@0.2.22
+ form_urlencoded@1.2.0
+ fs4@0.6.6
+ fsevent-sys@4.1.0
+ futures@0.3.28
+ futures-channel@0.3.28
+ futures-core@0.3.28
+ futures-executor@0.3.28
+ futures-io@0.3.28
+ futures-macro@0.3.28
+ futures-sink@0.3.28
+ futures-task@0.3.28
+ futures-util@0.3.28
+ getopts@0.2.21
+ getrandom@0.2.10
+ glob@0.3.1
+ hashbrown@0.12.3
+ hermit-abi@0.1.19
+ iana-time-zone@0.1.58
+ iana-time-zone-haiku@0.1.2
+ idna@0.4.0
+ indexmap@1.9.3
+ indoc@1.0.9
+ inotify@0.9.6
+ inotify-sys@0.1.5
+ itertools@0.10.5
+ itoa@1.0.9
+ js-sys@0.3.64
+ jsonrpc-core@18.0.0
+ kqueue@1.0.8
+ kqueue-sys@1.0.4
+ lazy_static@1.4.0
+ libc@0.2.149
+ libflate@1.4.0
+ libflate_lz77@1.2.0
+ linux-raw-sys@0.4.10
+ log@0.4.20
+ lsp-types@0.94.1
+ memchr@2.6.4
+ memoffset@0.9.0
+ mio@0.8.8
+ notify@5.2.0
+ num-traits@0.1.43
+ num-traits@0.2.17
+ num_threads@0.1.6
+ once_cell@1.18.0
+ os_str_bytes@6.6.1
+ percent-encoding@2.3.0
+ pin-project-lite@0.2.13
+ pin-utils@0.1.0
+ powerfmt@0.2.0
+ ppv-lite86@0.2.17
+ proc-macro2@1.0.69
+ pulldown-cmark@0.9.3
+ quote@1.0.33
+ rand@0.8.5
+ rand_chacha@0.3.1
+ rand_core@0.6.4
+ redox_syscall@0.2.16
+ redox_syscall@0.3.5
+ redox_users@0.4.3
+ regex@1.10.2
+ regex-automata@0.4.3
+ regex-syntax@0.8.2
+ rle-decode-fast@1.0.3
+ ropey@1.6.0
+ rustc_version@0.4.0
+ rustix@0.38.19
+ rustversion@1.0.14
+ ryu@1.0.15
+ same-file@1.0.6
+ semver@1.0.20
+ serde@1.0.189
+ serde_derive@1.0.189
+ serde_json@1.0.107
+ serde_repr@0.1.16
+ slab@0.4.9
+ slog@2.7.0
+ slog-async@2.8.0
+ slog-kvfilter@0.7.0
+ slog-scope@4.4.0
+ slog-stdlog@4.1.1
+ slog-term@2.9.0
+ sloggers@2.1.2
+ smallvec@1.11.1
+ str_indices@0.4.1
+ strsim@0.10.0
+ syn@1.0.109
+ syn@2.0.38
+ take_mut@0.2.2
+ term@0.7.0
+ termcolor@1.3.0
+ textwrap@0.16.0
+ thiserror@1.0.49
+ thiserror-impl@1.0.49
+ thread_local@1.1.7
+ time@0.3.30
+ time-core@0.1.2
+ time-macros@0.2.15
+ tinyvec@1.6.0
+ tinyvec_macros@0.1.1
+ toml@0.5.11
+ trackable@1.3.0
+ trackable_derive@1.0.0
+ unicase@2.7.0
+ unicode-bidi@0.3.13
+ unicode-ident@1.0.12
+ unicode-normalization@0.1.22
+ unicode-width@0.1.11
+ unindent@0.1.11
+ url@2.4.1
+ version_check@0.9.4
+ walkdir@2.4.0
+ wasi@0.11.0+wasi-snapshot-preview1
+ wasm-bindgen@0.2.87
+ wasm-bindgen-backend@0.2.87
+ wasm-bindgen-macro@0.2.87
+ wasm-bindgen-macro-support@0.2.87
+ wasm-bindgen-shared@0.2.87
+ web-sys@0.3.64
+ whoami@1.4.1
+ widestring@0.4.3
+ winapi@0.3.9
+ winapi-i686-pc-windows-gnu@0.4.0
+ winapi-util@0.1.6
+ winapi-x86_64-pc-windows-gnu@0.4.0
+ windows-acl@0.3.0
+ windows-core@0.51.1
+ windows-sys@0.45.0
+ windows-sys@0.48.0
+ windows-targets@0.42.2
+ windows-targets@0.48.5
+ windows_aarch64_gnullvm@0.42.2
+ windows_aarch64_gnullvm@0.48.5
+ windows_aarch64_msvc@0.42.2
+ windows_aarch64_msvc@0.48.5
+ windows_i686_gnu@0.42.2
+ windows_i686_gnu@0.48.5
+ windows_i686_msvc@0.42.2
+ windows_i686_msvc@0.48.5
+ windows_x86_64_gnu@0.42.2
+ windows_x86_64_gnu@0.48.5
+ windows_x86_64_gnullvm@0.42.2
+ windows_x86_64_gnullvm@0.48.5
+ windows_x86_64_msvc@0.42.2
+ windows_x86_64_msvc@0.48.5
+"
+
+inherit cargo
+
+DESCRIPTION="Kakoune Language Server Protocol Client"
+HOMEPAGE="https://github.com/kak-lsp/kak-lsp"
+SRC_URI="
+ https://github.com/kak-lsp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${CARGO_CRATE_URIS}
+"
+LICENSE="Apache-2.0 Apache-2.0-with-LLVM-exceptions Artistic-2 Boost-1.0 CC0-1.0 ISC MIT MPL-2.0 Unicode-DFS-2016 Unlicense ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+
+QA_FLAGS_IGNORED="usr/bin/kak-lsp"
+
+src_install() {
+ cargo_src_install
+}