aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/envycontrol/envycontrol-9999.ebuild')
-rw-r--r--sys-power/envycontrol/envycontrol-9999.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-power/envycontrol/envycontrol-9999.ebuild b/sys-power/envycontrol/envycontrol-9999.ebuild
new file mode 100644
index 000000000..23f9d4b9d
--- /dev/null
+++ b/sys-power/envycontrol/envycontrol-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit git-r3 distutils-r1
+
+EGIT_REPO_URI="https://github.com/bayasdev/envycontrol.git"
+DESCRIPTION="Easy GPU switching for Nvidia Optimus laptops under Linux"
+HOMEPAGE="https://github.com/bayasdev/envycontrol"
+
+LICENSE="MIT"
+SLOT="0"
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+}