aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-03-15 12:33:18 -0700
committerorbea <orbea@riseup.net>2024-03-15 12:33:18 -0700
commit13cd256709bc9c687ca99ef5fc9880718db6be6e (patch)
treee3a163c323b7c00e2e592a3218a1fcb55875af34 /dev-lang
parentapp-text/mupdf: stabilize 1.23.7-r1 (diff)
downloadlibressl-13cd256709bc9c687ca99ef5fc9880718db6be6e.tar.gz
libressl-13cd256709bc9c687ca99ef5fc9880718db6be6e.tar.bz2
libressl-13cd256709bc9c687ca99ef5fc9880718db6be6e.zip
dev-lang/python: sync ::gentoo
Signed-off-by: orbea <orbea@riseup.net>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.10.13_p3.ebuild2
-rw-r--r--dev-lang/python/python-3.11.8_p1.ebuild2
-rw-r--r--dev-lang/python/python-3.12.2_p1.ebuild2
-rw-r--r--dev-lang/python/python-3.9.18_p2.ebuild2
4 files changed, 8 insertions, 0 deletions
diff --git a/dev-lang/python/python-3.10.13_p3.ebuild b/dev-lang/python/python-3.10.13_p3.ebuild
index 8891b5c..ef4e8a6 100644
--- a/dev-lang/python/python-3.10.13_p3.ebuild
+++ b/dev-lang/python/python-3.10.13_p3.ebuild
@@ -248,6 +248,7 @@ src_configure() {
# They'll even hang here but be fine in src_test sometimes.
# bug #828535 (and related: bug #788022)
-x test_asyncio
+ -x test_concurrent_futures
-x test_httpservers
-x test_logging
-x test_multiprocessing_fork
@@ -385,6 +386,7 @@ src_test() {
-j "$(makeopts_jobs)"
# fails
+ -x test_concurrent_futures
-x test_gdb
)
diff --git a/dev-lang/python/python-3.11.8_p1.ebuild b/dev-lang/python/python-3.11.8_p1.ebuild
index 7ab2d9f..45389b7 100644
--- a/dev-lang/python/python-3.11.8_p1.ebuild
+++ b/dev-lang/python/python-3.11.8_p1.ebuild
@@ -238,6 +238,7 @@ src_configure() {
# They'll even hang here but be fine in src_test sometimes.
# bug #828535 (and related: bug #788022)
-x test_asyncio
+ -x test_concurrent_futures
-x test_httpservers
-x test_logging
-x test_multiprocessing_fork
@@ -402,6 +403,7 @@ src_test() {
-j "$(makeopts_jobs)"
# fails
+ -x test_concurrent_futures
-x test_gdb
)
diff --git a/dev-lang/python/python-3.12.2_p1.ebuild b/dev-lang/python/python-3.12.2_p1.ebuild
index 1249eca..9da529c 100644
--- a/dev-lang/python/python-3.12.2_p1.ebuild
+++ b/dev-lang/python/python-3.12.2_p1.ebuild
@@ -238,6 +238,7 @@ src_configure() {
# They'll even hang here but be fine in src_test sometimes.
# bug #828535 (and related: bug #788022)
-x test_asyncio
+ -x test_concurrent_futures
-x test_httpservers
-x test_logging
-x test_multiprocessing_fork
@@ -396,6 +397,7 @@ src_test() {
-j "$(makeopts_jobs)"
# fails
+ -x test_concurrent_futures
-x test_gdb
)
diff --git a/dev-lang/python/python-3.9.18_p2.ebuild b/dev-lang/python/python-3.9.18_p2.ebuild
index 361c4ba..ea5bea1 100644
--- a/dev-lang/python/python-3.9.18_p2.ebuild
+++ b/dev-lang/python/python-3.9.18_p2.ebuild
@@ -175,6 +175,7 @@ src_configure() {
# They'll even hang here but be fine in src_test sometimes.
# bug #828535 (and related: bug #788022)
-x test_asyncio
+ -x test_concurrent_futures
-x test_httpservers
-x test_logging
-x test_multiprocessing_fork
@@ -369,6 +370,7 @@ src_test() {
-j "$(makeopts_jobs)"
# fails
+ -x test_concurrent_futures
-x test_gdb
)