aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2020-07-16 19:02:16 +0300
committerStefan Strogin <steils@gentoo.org>2020-07-16 19:02:16 +0300
commita04f50ff5a4bc0cc9a9483a14173b912071dea38 (patch)
tree87d7cc88f3cea0141c83465bb00ab989004306af
parentgui-libs/libhandy: merged inside gentoo, drop here (diff)
downloadmatrix-a04f50ff5a4bc0cc9a9483a14173b912071dea38.tar.gz
matrix-a04f50ff5a4bc0cc9a9483a14173b912071dea38.tar.bz2
matrix-a04f50ff5a4bc0cc9a9483a14173b912071dea38.zip
net-im/riot-desktop: upgrade to 1.6.8
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Stefan Strogin <steils@gentoo.org>
-rw-r--r--net-im/riot-desktop/Manifest2
-rw-r--r--net-im/riot-desktop/riot-desktop-1.6.8.ebuild116
2 files changed, 118 insertions, 0 deletions
diff --git a/net-im/riot-desktop/Manifest b/net-im/riot-desktop/Manifest
index d7a4bc4..a7a3eb3 100644
--- a/net-im/riot-desktop/Manifest
+++ b/net-im/riot-desktop/Manifest
@@ -1,4 +1,6 @@
DIST riot-desktop-1.6.2.tar.gz 401236 BLAKE2B 0df29f11778d85988b4368de974c2e3ce62b3dfdda4b0c063def27d6bad9ed01814fb85c195aedfc0133b5da34fb49ddb5935fd0ef7149f274f76fcb75056791 SHA512 9709a4704aaef0e670c734c17d2499cd3299cd6cfc3160cda2a9f88954823a47874d619442e25c4f4a35182174db939f95017977af62037471daeae7b61ee666
DIST riot-desktop-1.6.4.tar.gz 401961 BLAKE2B 422d975527bfdc70a928239ce2cd7de8079dd8e6d4434469a2cc9f5a4ea70b00f2c271d002e90a6099dfa19ba40e1f46ebba65fffcea4def8e0974b9b422d538 SHA512 316769922ec55098b4ab4aa69c9636de622551365a2dbcf297594559b4aac6388853e01eb7ecdf9a36f840fac9bbc94c56e29164abed9abdda5aef98adcee832
+DIST riot-desktop-1.6.8.tar.gz 405369 BLAKE2B c448bc67fc55855100a01e7069fb258b243c54ca6cc4efa356c4c44807e881f6d9c54f31d880591d10209aaca1972102fdf855f3bdfe4d50c0da28efd75be2af SHA512 2120ef7866b875df14ec3ecfd8bb40ee3821ae273a888f923a054a4358ef28b60735cc7322b45d80b9a90064cdfe3136617752f87f4d3c5fdea3b3aa3abeb12c
DIST riot-web-1.6.2.tar.gz 1150424 BLAKE2B 47436ac75160338abe2c38991256fb4ee6587433d6635e36d761c2d01c35cbc8a9585756da1bd9681c9385828661e0b4d9eeb8fd49bf6b6d70329b1aa205b024 SHA512 0b6287f806f14b7408315d34935b7f7f5f36d23e3bf5870141747ec988c9f30acfc74281103369b7b2ee30709c4a89c998c7855a917fd0cedd455dd0156128ec
DIST riot-web-1.6.4.tar.gz 1154013 BLAKE2B bc45663eba3b69661aef09583523c4d5f05f5c0dcfc737ce6a36ecebd826d37ee19f0ce948cbdd19e309bff00468afd6663c39227f8b3302b84859164a3565be SHA512 69952c6ae58624b668ef0a0defb316e23fc5b040060aec2b0546970c391ea94387802c10d762c8a0af53796fc710b68eb3850c3e10c689b9ab0f1c58edb91d46
+DIST riot-web-1.6.8.tar.gz 1157404 BLAKE2B 22fb9a2da292e12917b3a4d21a85df99631cc7d35b8ac3acd6f35a2e553f2678046bafe8fd02d4000578aa7eb708d2696ea172c86a27a72bac9c1bacb6af8d49 SHA512 48f1b09ee87037c4b05fddf45d7406400e674c6a060a17cfea587098062df70e46748c8835c43e2b82cbe72e43ce319921f98e3f94196a1773b3eb51ca9e8e66
diff --git a/net-im/riot-desktop/riot-desktop-1.6.8.ebuild b/net-im/riot-desktop/riot-desktop-1.6.8.ebuild
new file mode 100644
index 0000000..f6b486f
--- /dev/null
+++ b/net-im/riot-desktop/riot-desktop-1.6.8.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A glossy Matrix collaboration client for desktop"
+HOMEPAGE="https://riot.im"
+
+inherit unpacker xdg-utils
+
+SRC_URI="https://github.com/vector-im/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/vector-im/riot-web/archive/v${PV}.tar.gz -> riot-web-${PV}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+emoji"
+REQUIRED_USE=""
+
+RESTRICT="network-sandbox"
+
+RDEPEND="app-accessibility/at-spi2-atk:2
+ dev-db/sqlcipher
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/nspr
+ dev-libs/nss
+ >=net-libs/nodejs-12.14.0
+ net-print/cups
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+ emoji? ( media-fonts/noto-emoji )"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-apps/yarn
+ virtual/rust"
+
+QA_PREBUILT="
+ /opt/Riot/chrome-sandbox
+ /opt/Riot/riot-desktop
+ /opt/Riot/libEGL.so
+ /opt/Riot/libGLESv2.so
+ /opt/Riot/libffmpeg.so
+ /opt/Riot/libvk_swiftshader.so
+ /opt/Riot/swiftshader/libEGL.so
+ /opt/Riot/swiftshader/libGLESv2.so"
+
+RIOT_WEB_S="${WORKDIR}/riot-web-${PV}"
+
+src_prepare() {
+ default
+ pushd "${RIOT_WEB_S}" >/dev/null || die
+ yarn install || die
+ cp config.sample.json config.json || die
+
+ popd || die
+ yarn install || die
+}
+
+src_compile() {
+ pushd "${RIOT_WEB_S}" >/dev/null || die
+ yarn build || die
+
+ popd || die
+ ln -s "${RIOT_WEB_S}"/webapp ./ || die
+ yarn build:native || die
+ yarn build || die
+}
+
+src_install() {
+ unpack dist/${PN}_${PV}_amd64.deb
+ tar -xvf data.tar.xz || die
+
+ ./node_modules/asar/bin/asar.js p webapp opt/Riot/resources/webapp.asar || die
+ mv usr/share/doc/${PN} usr/share/doc/${PF} || die
+ gunzip usr/share/doc/${PF}/changelog.gz || die
+
+ insinto /
+ doins -r usr
+ doins -r opt
+ local f
+ for f in ${QA_PREBUILT}; do
+ fperms +x "${f}"
+ done
+ dosym ../../opt/Riot/${PN} /usr/bin/${PN}
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ elog "Since upgrading Riot to Electron 8 it uses StatusNotifierItem"
+ elog "for displaying the tray icon."
+ elog "Some popular status bars do not support the new API."
+ elog
+ elog "If you have problems with showing the tray icon, consider installing"
+ elog "x11-misc/snixembed."
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}