aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2020-05-30 00:08:36 +0300
committerStefan Strogin <steils@gentoo.org>2020-05-30 00:09:14 +0300
commitafd1c072e696d2f8d222b3000361897dcc708342 (patch)
treed7f5643c369b757f1b8a10345b37769da94d805e
parentnet-im/riot-desktop: add missing dev-db/sqlcipher dependency (diff)
downloadmatrix-afd1c072e696d2f8d222b3000361897dcc708342.tar.gz
matrix-afd1c072e696d2f8d222b3000361897dcc708342.tar.bz2
matrix-afd1c072e696d2f8d222b3000361897dcc708342.zip
net-im/riot-desktop: version bump to 1.6.2
Add dependencies: app-accessibility/at-spi2-atk:2 dev-libs/atk dev-libs/expat dev-libs/nspr x11-libs/cairo x11-libs/gdk-pixbuf:2 x11-libs/gtk+:3 x11-libs/libxcb x11-libs/libX11 x11-libs/libXcomposite x11-libs/libXcursor x11-libs/libXdamage x11-libs/libXext x11-libs/libXfixes x11-libs/libXi x11-libs/libXrandr x11-libs/libXrender x11-libs/libXtst x11-libs/pango Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Stefan Strogin <steils@gentoo.org>
-rw-r--r--net-im/riot-desktop/Manifest2
-rw-r--r--net-im/riot-desktop/riot-desktop-1.6.2.ebuild117
2 files changed, 119 insertions, 0 deletions
diff --git a/net-im/riot-desktop/Manifest b/net-im/riot-desktop/Manifest
index a29f8a6..7c4b450 100644
--- a/net-im/riot-desktop/Manifest
+++ b/net-im/riot-desktop/Manifest
@@ -1,3 +1,5 @@
DIST riot-desktop-1.5.13.tar.gz 1402204 BLAKE2B 11c17baff2e55b2d5529f23035741bd66e3404fa86ea044aba9c43473abb93bd7a145c87591ec432c27e214ae8f6799a1fffac82285f7c9d36e39235e86ad0cc SHA512 8464ac47a720734c02eadbcc0e0bbfc439f0722e60a580b2969d16aab67f746e432737209a751671177627137900fd183f32b306ecc8b0be13015c436e9e6431
DIST riot-desktop-1.6.1.tar.gz 401222 BLAKE2B dbc3aaefce9a727025c341b03c657edd348eabd22efd2285558939d460941ad85adae65d9e13be2445baaf958f018f6afa071670eae81d13e875abbbf62417af SHA512 8ff8ba30088d0caee6a45fbd1b7b70554b69344603d93d9c555be0dc4120a4dcfe99819ca06deab8bd66f535761215a832f2e69084b61738a1263497e185b404
+DIST riot-desktop-1.6.2.tar.gz 401236 BLAKE2B 0df29f11778d85988b4368de974c2e3ce62b3dfdda4b0c063def27d6bad9ed01814fb85c195aedfc0133b5da34fb49ddb5935fd0ef7149f274f76fcb75056791 SHA512 9709a4704aaef0e670c734c17d2499cd3299cd6cfc3160cda2a9f88954823a47874d619442e25c4f4a35182174db939f95017977af62037471daeae7b61ee666
DIST riot-web-1.6.1.tar.gz 1150368 BLAKE2B 51437fa1e0a8e62ca34dcae2701b807bba95c2071439ffff129812b975c997afc867cffd3aceef926358eeecab82b615d91b90b08672465052f695573052c2f4 SHA512 36603d19984aed6586100497a35642e061d5d8a679ff10c18e24a6bb7c865a7262e4fd57d42085e7cd7df0d6563408cb031b2c07ca73b57f11791095ac499028
+DIST riot-web-1.6.2.tar.gz 1150424 BLAKE2B 47436ac75160338abe2c38991256fb4ee6587433d6635e36d761c2d01c35cbc8a9585756da1bd9681c9385828661e0b4d9eeb8fd49bf6b6d70329b1aa205b024 SHA512 0b6287f806f14b7408315d34935b7f7f5f36d23e3bf5870141747ec988c9f30acfc74281103369b7b2ee30709c4a89c998c7855a917fd0cedd455dd0156128ec
diff --git a/net-im/riot-desktop/riot-desktop-1.6.2.ebuild b/net-im/riot-desktop/riot-desktop-1.6.2.ebuild
new file mode 100644
index 0000000..a512fd1
--- /dev/null
+++ b/net-im/riot-desktop/riot-desktop-1.6.2.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A glossy Matrix collaboration client for desktop"
+HOMEPAGE="https://riot.im"
+
+inherit unpacker xdg-utils
+
+SRC_URI="https://github.com/vector-im/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/vector-im/riot-web/archive/v${PV}.tar.gz -> riot-web-${PV}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+emoji"
+REQUIRED_USE=""
+
+RESTRICT="network-sandbox"
+
+RDEPEND="app-accessibility/at-spi2-atk:2
+ dev-db/sqlcipher
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/nspr
+ dev-libs/nss
+ >=net-libs/nodejs-12.14.0
+ net-print/cups
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+ emoji? ( media-fonts/noto-emoji )"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-apps/yarn
+ virtual/rust"
+
+QA_PREBUILT="
+ /opt/Riot/chrome-sandbox
+ /opt/Riot/crashpad_handler
+ /opt/Riot/riot-desktop
+ /opt/Riot/libEGL.so
+ /opt/Riot/libGLESv2.so
+ /opt/Riot/libffmpeg.so
+ /opt/Riot/libvk_swiftshader.so
+ /opt/Riot/swiftshader/libEGL.so
+ /opt/Riot/swiftshader/libGLESv2.so"
+
+RIOT_WEB_S="${WORKDIR}/riot-web-${PV}"
+
+src_prepare() {
+ default
+ pushd "${RIOT_WEB_S}" >/dev/null || die
+ yarn install || die
+ cp config.sample.json config.json || die
+
+ popd || die
+ yarn install || die
+}
+
+src_compile() {
+ pushd "${RIOT_WEB_S}" >/dev/null || die
+ yarn build || die
+
+ popd || die
+ ln -s "${RIOT_WEB_S}"/webapp ./ || die
+ yarn build:native || die
+ yarn build || die
+}
+
+src_install() {
+ unpack dist/${PN}_${PV}_amd64.deb
+ tar -xvf data.tar.xz || die
+
+ ./node_modules/asar/bin/asar.js p webapp opt/Riot/resources/webapp.asar || die
+ mv usr/share/doc/${PN} usr/share/doc/${PF} || die
+ gunzip usr/share/doc/${PF}/changelog.gz || die
+
+ insinto /
+ doins -r usr
+ doins -r opt
+ local f
+ for f in ${QA_PREBUILT}; do
+ fperms +x "${f}"
+ done
+ dosym ../../opt/Riot/${PN} /usr/bin/${PN}
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ elog "Since upgrading Riot to Electron 8 it uses StatusNotifierItem"
+ elog "for displaying the tray icon."
+ elog "Some popular status bars do not support the new API."
+ elog
+ elog "If you have problems with showing the tray icon, consider installing"
+ elog "x11-misc/snixembed."
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}