aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/helix/helix-0.7.5.ebuild')
-rw-r--r--dev-ruby/helix/helix-0.7.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/helix/helix-0.7.5.ebuild b/dev-ruby/helix/helix-0.7.5.ebuild
new file mode 100644
index 0000000..6784db4
--- /dev/null
+++ b/dev-ruby/helix/helix-0.7.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2017-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# Auto-Generated by cargo-ebuild 0.1.5
+
+EAPI=6
+
+CRATES="
+cstr-macro-0.1.0
+helix-0.7.5
+libc-0.2.43
+libcruby-sys-0.7.5
+"
+
+inherit cargo
+
+DESCRIPTION="Embed Rust in your Ruby"
+HOMEPAGE="https://usehelix.com"
+SRC_URI="$(cargo_crate_uris ${CRATES})"
+RESTRICT="mirror"
+LICENSE="ISC" # Update to proper Gentoo format
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+# example crates for demos https://github.com/tildeio/helix/tree/master/examples/ are sources... each can have ebuids
+# more of a pain to add ?(examples and all the bleeping deps)