summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-05 18:05:30 -0500
committerSam James <sam@gentoo.org>2024-03-06 03:36:18 +0000
commit214dbaa6ba17af414093d38e2310b48a0e01967e (patch)
treeae664bb14bd58295f3f1027b0cf250fd9c749398
parentmedia-gfx/arss: mark as LTO-unsafe, strict-aliasing unsafe (diff)
downloadgentoo-214dbaa6ba17af414093d38e2310b48a0e01967e.tar.gz
gentoo-214dbaa6ba17af414093d38e2310b48a0e01967e.tar.bz2
gentoo-214dbaa6ba17af414093d38e2310b48a0e01967e.zip
games-fps/rott: mark as LTO-unsafe
The upstream website is being clever and suggesting that distros are the real upstreams, and that releases happen by, every couple of years, collecting all the patches distros have applied and turning that into a release. Hopeless. No bug reporting mechanism. Closes: https://bugs.gentoo.org/858758 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--games-fps/rott/rott-1.1.2-r1.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/games-fps/rott/rott-1.1.2-r1.ebuild b/games-fps/rott/rott-1.1.2-r1.ebuild
index a11a0d2074c1..7b80302df3e4 100644
--- a/games-fps/rott/rott-1.1.2-r1.ebuild
+++ b/games-fps/rott/rott-1.1.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Rise of the Triad for Linux!"
HOMEPAGE="https://www.icculus.org/rott/"
@@ -33,6 +33,18 @@ src_prepare() {
}
src_compile() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/858758
+ #
+ # The upstream homepage notes that you should send bug reports and feature
+ # requests to your distro. Rationale: "1.1.2 contains all the debian
+ # patches from the previous 2.5 years" and "1.1.1. contains all the debian
+ # and fedora patches that accumulated during the past year."
+ #
+ # This is an interesting collaborative model that unfortunately means there
+ # will be NO bug report.
+ filter-lto
+
tc-export CC
emake -j1 \
EXTRACFLAGS="${CFLAGS} -DDATADIR=\\\"/usr/share/${PN}/\\\"" \