summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-04-20 20:58:29 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-04-20 20:59:00 +0200
commit296f14a222a1cb690b376b2e4617d95250d1602c (patch)
tree2e9b9f722a1e909f231226a90c62dfdc1399b655
parentdev-java/tomcat-servlet-api: drop 7.0.109 (diff)
downloadgentoo-296f14a222a1cb690b376b2e4617d95250d1602c.tar.gz
gentoo-296f14a222a1cb690b376b2e4617d95250d1602c.tar.bz2
gentoo-296f14a222a1cb690b376b2e4617d95250d1602c.zip
dev-ml/core_unix: don't use gcc directly
Closes: https://bugs.gentoo.org/892469 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-ml/core_unix/core_unix-0.15.2-r1.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-ml/core_unix/core_unix-0.15.2-r1.ebuild b/dev-ml/core_unix/core_unix-0.15.2-r1.ebuild
index c543a96d0275..afbc6c1676e2 100644
--- a/dev-ml/core_unix/core_unix-0.15.2-r1.ebuild
+++ b/dev-ml/core_unix/core_unix-0.15.2-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit dune
+inherit dune toolchain-funcs
DESCRIPTION="Unix-specific portions of Core"
HOMEPAGE="https://github.com/janestreet/core_unix"
@@ -25,3 +25,12 @@ DEPEND="
"
RDEPEND="${DEPEND}"
BDEPEND=""
+
+src_prepare() {
+ sed -i \
+ -e "s:gcc:$(tc-getCC):" \
+ unix_pseudo_terminal/src/discover.sh \
+ || die
+
+ default
+}