summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 06:12:27 +0100
committerSam James <sam@gentoo.org>2021-04-13 00:26:13 +0000
commit9d7d59894e67667decb021c618e59232481d0c1a (patch)
treeda13c20ed118127506e0d87d0707894b76e98001
parentgames-fps/darkplaces: call pkg-config via toolchain-funcs.eclass helper (diff)
downloadgentoo-9d7d59894e67667decb021c618e59232481d0c1a.tar.gz
gentoo-9d7d59894e67667decb021c618e59232481d0c1a.tar.bz2
gentoo-9d7d59894e67667decb021c618e59232481d0c1a.zip
games-puzzle/zaz: call pkg-config via toolchain-funcs.eclass helper
This ensures we call the correct pkg-config in e.g. cross. Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--games-puzzle/zaz/zaz-1.0.0-r1.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/games-puzzle/zaz/zaz-1.0.0-r1.ebuild b/games-puzzle/zaz/zaz-1.0.0-r1.ebuild
index 4a3321038e57..ba80059c7f1d 100644
--- a/games-puzzle/zaz/zaz-1.0.0-r1.ebuild
+++ b/games-puzzle/zaz/zaz-1.0.0-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools flag-o-matic xdg
+
+inherit autotools flag-o-matic xdg toolchain-funcs
DESCRIPTION="A puzzle game where the player has to arrange balls in triplets"
HOMEPAGE="https://sourceforge.net/projects/zaz/"
@@ -39,8 +40,8 @@ src_prepare() {
src_configure() {
append-libs -lvorbis
- append-cflags $(pkg-config sdl --cflags)
- append-cxxflags $(pkg-config sdl --cflags)
+ append-cflags $($(tc-getPKG_CONFIG) sdl --cflags)
+ append-cxxflags $($(tc-getPKG_CONFIG) sdl --cflags)
econf \
--with-applicationdir=/usr/share/applications \
--with-icondir=/usr/share/pixmaps \