summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-06-16 07:41:39 +0200
committerHans de Graaff <graaff@gentoo.org>2017-06-16 07:41:39 +0200
commita6b03d3ebc77970b157f9939d052e90b29fc598a (patch)
treea6f8e09c96cbc7e62ac1502bbf21bad3b9271f95
parentdev-ruby/logue: add 1.0.8 (diff)
downloadgentoo-a6b03d3ebc77970b157f9939d052e90b29fc598a.tar.gz
gentoo-a6b03d3ebc77970b157f9939d052e90b29fc598a.tar.bz2
gentoo-a6b03d3ebc77970b157f9939d052e90b29fc598a.zip
dev-ruby/launchy: add ruby24
Package-Manager: Portage-2.3.5, Repoman-2.3.1
-rw-r--r--dev-ruby/launchy/launchy-2.4.3-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/launchy/launchy-2.4.3-r2.ebuild b/dev-ruby/launchy/launchy-2.4.3-r2.ebuild
new file mode 100644
index 000000000000..623da4e9afbc
--- /dev/null
+++ b/dev-ruby/launchy/launchy-2.4.3-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_EXTRADOC="README.md HISTORY.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Helper class for launching cross-platform applications"
+HOMEPAGE="https://github.com/copiousfreetime/launchy"
+
+LICENSE="ISC"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# File collision conflict with x11-misc/launchy, bug 545170
+ruby_add_rdepend ">=dev-ruby/addressable-2.3 !!x11-misc/launchy"
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.0:5 )"
+
+# This test is expected to fail on linux, drop it
+RUBY_PATCHES=( "${FILESDIR}"/${PN}-2.4.2-drop-failing-test.patch )
+
+all_ruby_prepare() {
+ sed -i -e "/[Ss]implecov/d" spec/spec_helper.rb || die
+
+ # Avoid tests depending on the current user's desktop environment.
+ sed -e '/returns NotFound if it cannot determine/askip "gentoo"' \
+ -i spec/detect/nix_desktop_environment_spec.rb || die
+ sed -e '/asssumes we open a local file if we have an exception/askip "gentoo"' \
+ -i spec/launchy_spec.rb || die
+}