summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLei Zhang <zhanglei.april@gmail.com>2016-09-18 18:27:12 +0800
committerMichał Górny <mgorny@gentoo.org>2016-09-29 15:24:29 +0200
commitd7f58d48e5faeeaca1b35efd557ae9171f770388 (patch)
treee28d76819b664072f12af6809e1f80d66ce287e2
parentmedia-libs/openjpeg: arm stable wrt bug #594740 (diff)
downloadgentoo-d7f58d48e5faeeaca1b35efd557ae9171f770388.tar.gz
gentoo-d7f58d48e5faeeaca1b35efd557ae9171f770388.tar.bz2
gentoo-d7f58d48e5faeeaca1b35efd557ae9171f770388.zip
sys-libs/libomp: bump to 3.9.0
Closes: https://github.com/gentoo/gentoo/pull/2426 Package-Manager: portage-2.3.0
-rw-r--r--sys-libs/libomp/Manifest1
-rw-r--r--sys-libs/libomp/files/libomp-3.9.0-optional-aliases.patch63
-rw-r--r--sys-libs/libomp/libomp-3.9.0.ebuild40
3 files changed, 104 insertions, 0 deletions
diff --git a/sys-libs/libomp/Manifest b/sys-libs/libomp/Manifest
index d6186a4ded38..e33c970b0f88 100644
--- a/sys-libs/libomp/Manifest
+++ b/sys-libs/libomp/Manifest
@@ -2,3 +2,4 @@ DIST openmp-3.7.0.src.tar.xz 2251108 SHA256 8d8a224e5689596a35652fda87e4be29853c
DIST openmp-3.7.1.src.tar.xz 2026988 SHA256 9a702e20c247014f6de8c45b738c6ea586eca0559304520f565ac9a7cba4bf9a SHA512 ec29f2665c9de4dee184f86a980a90c87a99e7728bb9c46c9e513801c30b28b6496bfcfbe4cefbd90ef63b761886cd74c19cf8e26a8854d8569e357b78633f6a WHIRLPOOL e69f2ef825df7f438db3647d2405d0fe6e6b00d8614efe0783e1fef5ae72db11b4a5f231383f3cc66402cb0785a025610187cc69fba2edbafa51136bd990453e
DIST openmp-3.8.0.src.tar.xz 2233144 SHA256 92510e3f62e3de955e3a0b6708cebee1ca344d92fb02369cba5fdd5c68f773a0 SHA512 46d5a87855237308d1df36fa2c0a22a26b682e2db21ef804c5ba805e0e700fa89473ec3178195a932bf9cb53179c155f4048a036ff566165822a274cbb6302a4 WHIRLPOOL c5ffb78ce3f94b837ecd349637d19bcfaef589553e3708c651822042eb25abef81639e0a7d6c221bb15942d24f4ee5ed5431f170b763b09bfd471a391646df5e
DIST openmp-3.8.1.src.tar.xz 2009572 SHA256 68fcde6ef34e0275884a2de3450a31e931caf1d6fda8606ef14f89c4123617dc SHA512 406e9077817c50bcd58dd50bd334258ebf4b81c3ecce830ae1f427bd7c1fc9376b63fdeb3459c953c341becde82d83be18069bfcd34cbaeee6f1478267c0b2bc WHIRLPOOL b733b7f8f965be86af49af5b02892ec8aacaafe00d310a21c8cc0155f1699da66d1c8aa7709eb230810c4ff68f63896d5a7548777c100ca91a8af998922bdca0
+DIST openmp-3.9.0.src.tar.xz 2257596 SHA256 df88f90d7e5b5e9525a35fa2e2b93cbbb83c4882f91df494e87ee3ceddacac91 SHA512 030432bb10d86016f0f1c4f4d8b25f78acdb4aed33c604baf07c825bbcc6198306f2f71a3e56030f20864a92ab0187357aff94d34e47f7166991faf539c0104d WHIRLPOOL 7bfb362c0f087d3867c8cab04ebba23c8e6337d34ddcdfeda1cbe960611eacf1e4356e99bf4d6316b60c9f4b9f9fb23eecdb346feaae72b9cd168ee0aa3cca2a
diff --git a/sys-libs/libomp/files/libomp-3.9.0-optional-aliases.patch b/sys-libs/libomp/files/libomp-3.9.0-optional-aliases.patch
new file mode 100644
index 000000000000..faf5bb51bca9
--- /dev/null
+++ b/sys-libs/libomp/files/libomp-3.9.0-optional-aliases.patch
@@ -0,0 +1,63 @@
+From 89ab78e360b7b20ebe1bc89736880a8e4aaa9e6e Mon Sep 17 00:00:00 2001
+From: Michal Gorny <mgorny@gentoo.org>
+Date: Wed, 14 Sep 2016 17:46:27 +0000
+Subject: [PATCH] [cmake] Make libgomp & libiomp5 alias install optional
+
+Introduce a new LIBOMP_INSTALL_VARIABLES cache variable that can be used
+to disable creating libgomp and libiomp5 aliases on 'make install'.
+Those aliases are undesired e.g. on Gentoo systems where libomp is used
+purely by clang.
+
+Differential Revision: https://reviews.llvm.org/D24563
+
+git-svn-id: https://llvm.org/svn/llvm-project/openmp/trunk@281512 91177308-0d34-0410-b5e6-96231b3b80d8
+---
+ runtime/CMakeLists.txt | 4 ++++
+ runtime/src/CMakeLists.txt | 16 +++++++++-------
+ 2 files changed, 13 insertions(+), 7 deletions(-)
+
+diff --git a/runtime/CMakeLists.txt b/runtime/CMakeLists.txt
+index 9db058b..e8e9a74 100644
+--- a/runtime/CMakeLists.txt
++++ b/runtime/CMakeLists.txt
+@@ -340,6 +340,10 @@ endif()
+
+ set(LIBOMP_LIB_FILE ${LIBOMP_LIB_NAME}${LIBOMP_LIBRARY_SUFFIX})
+
++# Optional backwards compatibility aliases.
++set(LIBOMP_INSTALL_ALIASES TRUE CACHE BOOL
++ "Install libgomp and libiomp5 library aliases for backwards compatibility")
++
+ # Print configuration after all variables are set.
+ if(${LIBOMP_STANDALONE_BUILD})
+ libomp_say("Operating System -- ${CMAKE_SYSTEM_NAME}")
+diff --git a/runtime/src/CMakeLists.txt b/runtime/src/CMakeLists.txt
+index 777434d..c80f88d 100644
+--- a/runtime/src/CMakeLists.txt
++++ b/runtime/src/CMakeLists.txt
+@@ -305,13 +305,15 @@ else()
+
+ install(TARGETS omp ${LIBOMP_INSTALL_KIND} DESTINATION lib${LIBOMP_LIBDIR_SUFFIX})
+
+- # Create aliases (symlinks) of the library for backwards compatibility
+- set(LIBOMP_ALIASES "libgomp;libiomp5")
+- foreach(alias IN LISTS LIBOMP_ALIASES)
+- install(CODE "execute_process(COMMAND \"\${CMAKE_COMMAND}\" -E create_symlink \"${LIBOMP_LIB_FILE}\"
+- \"${alias}${LIBOMP_LIBRARY_SUFFIX}\" WORKING_DIRECTORY
+- \$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/lib${LIBOMP_LIBDIR_SUFFIX})")
+- endforeach()
++ if(${LIBOMP_INSTALL_ALIASES})
++ # Create aliases (symlinks) of the library for backwards compatibility
++ set(LIBOMP_ALIASES "libgomp;libiomp5")
++ foreach(alias IN LISTS LIBOMP_ALIASES)
++ install(CODE "execute_process(COMMAND \"\${CMAKE_COMMAND}\" -E create_symlink \"${LIBOMP_LIB_FILE}\"
++ \"${alias}${LIBOMP_LIBRARY_SUFFIX}\" WORKING_DIRECTORY
++ \$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/lib${LIBOMP_LIBDIR_SUFFIX})")
++ endforeach()
++ endif()
+ endif()
+ install(
+ FILES
+--
+2.4.10
+
diff --git a/sys-libs/libomp/libomp-3.9.0.ebuild b/sys-libs/libomp/libomp-3.9.0.ebuild
new file mode 100644
index 000000000000..856ea692af71
--- /dev/null
+++ b/sys-libs/libomp/libomp-3.9.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+
+inherit cmake-multilib
+
+MY_P=openmp-${PV}
+DESCRIPTION="OpenMP runtime library for LLVM/clang compiler"
+HOMEPAGE="http://openmp.llvm.org"
+SRC_URI="http://llvm.org/releases/${PV}/${MY_P}.src.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0/3.9"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+
+S="${WORKDIR}/${MY_P}.src"
+
+PATCHES=(
+ # backport of https://reviews.llvm.org/D24563
+ "${FILESDIR}"/${PN}-3.9.0-optional-aliases.patch
+)
+
+multilib_src_configure() {
+ local libdir="$(get_libdir)"
+ local mycmakeargs=(
+ -DLIBOMP_LIBDIR_SUFFIX="${libdir#lib}"
+ # do not install libgomp.so & libiomp5.so aliases
+ -DLIBOMP_INSTALL_ALIASES=OFF
+ # disable unnecessary hack copying stuff back to srcdir
+ -DLIBOMP_COPY_EXPORTS=OFF
+ )
+ cmake-utils_src_configure
+}