summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-12-31 11:54:39 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-01-07 01:19:32 +0100
commitfa2962c4a96704f4ce86998995c53c2a0f86c260 (patch)
tree82244d6e46f20656e6968b286eead394ab1450a2 /app-admin/cronolog/cronolog-1.6.2-r7.ebuild
parentapp-arch/lzlib: fix calling AR directly, bug #721916 (diff)
downloadgentoo-fa2962c4a96704f4ce86998995c53c2a0f86c260.tar.gz
gentoo-fa2962c4a96704f4ce86998995c53c2a0f86c260.tar.bz2
gentoo-fa2962c4a96704f4ce86998995c53c2a0f86c260.zip
app-admin/cronolog: fix calling ar directly, bug #721908
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://bugs.gentoo.org/721908 Closes: https://github.com/gentoo/gentoo/pull/34575 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-admin/cronolog/cronolog-1.6.2-r7.ebuild')
-rw-r--r--app-admin/cronolog/cronolog-1.6.2-r7.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/cronolog/cronolog-1.6.2-r7.ebuild b/app-admin/cronolog/cronolog-1.6.2-r7.ebuild
new file mode 100644
index 000000000000..32788154300e
--- /dev/null
+++ b/app-admin/cronolog/cronolog-1.6.2-r7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Log rotation software"
+HOMEPAGE="https://github.com/fordmason/cronolog"
+SRC_URI="http://cronolog.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2+ Apache-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-patches
+ # rename and move into ${PV}-patches after -r3 removal
+ "${FILESDIR}"/${P}-umask.patch
+)
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}