summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-10 12:38:29 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-10 12:38:29 +0200
commit56d70180b363f15bebcef15638a8464db5074fe9 (patch)
treed6833f18ec7901ebe20e6612c24b4bde5a2e6d42 /app-arch/unace
parentapp-arch/unadf: update EAPI 6 -> 8 (diff)
downloadgentoo-56d70180b363f15bebcef15638a8464db5074fe9.tar.gz
gentoo-56d70180b363f15bebcef15638a8464db5074fe9.tar.bz2
gentoo-56d70180b363f15bebcef15638a8464db5074fe9.zip
app-arch/unace: update EAPI 6 -> 8
Closes: https://bugs.gentoo.org/716126 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-arch/unace')
-rw-r--r--app-arch/unace/files/unace-2.5-includes.patch10
-rw-r--r--app-arch/unace/unace-2.5-r6.ebuild (renamed from app-arch/unace/unace-2.5-r5.ebuild)14
2 files changed, 19 insertions, 5 deletions
diff --git a/app-arch/unace/files/unace-2.5-includes.patch b/app-arch/unace/files/unace-2.5-includes.patch
new file mode 100644
index 000000000000..ca272a185041
--- /dev/null
+++ b/app-arch/unace/files/unace-2.5-includes.patch
@@ -0,0 +1,10 @@
+--- a/source/base/all/uninorm/unincore.c
++++ b/source/base/all/uninorm/unincore.c
+@@ -19,6 +19,7 @@
+ #include <string.h>
+ #include "base/all/includes.h" /* BASE_LFN_MAXLEN */
+ #include "unidata.h"
++#include "unincore.h"
+
+ /* Hangul constants */
+ #define SBase 0xAC00
diff --git a/app-arch/unace/unace-2.5-r5.ebuild b/app-arch/unace/unace-2.5-r6.ebuild
index fd5a75cbe2f2..f8dbaf5919a5 100644
--- a/app-arch/unace/unace-2.5-r5.ebuild
+++ b/app-arch/unace/unace-2.5-r6.ebuild
@@ -1,22 +1,26 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=8
inherit toolchain-funcs
DEB_VER="9"
+
DESCRIPTION="ACE unarchiver"
HOMEPAGE="http://www.winace.com/"
-SRC_URI="mirror://debian/pool/non-free/u/unace-nonfree/unace-nonfree_${PV}.orig.tar.gz
+SRC_URI="
+ mirror://debian/pool/non-free/u/unace-nonfree/unace-nonfree_${PV}.orig.tar.gz
mirror://debian/pool/non-free/u/unace-nonfree/unace-nonfree_${PV}-${DEB_VER}.debian.tar.xz"
LICENSE="freedist"
SLOT="1"
KEYWORDS="~alpha amd64 arm ~hppa ppc ppc64 ~s390 x86 ~amd64-linux ~x86-linux ~sparc-solaris"
-IUSE=""
-PATCHES=( "${WORKDIR}"/debian/patches/ )
+PATCHES=(
+ "${WORKDIR}"/debian/patches/
+ "${FILESDIR}"/${P}-includes.patch
+)
src_configure() {
tc-export CC