summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 20:17:23 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:54:57 +0100
commit16984ec2d2a87b6ccf9db4fb3bd09e291537c707 (patch)
tree367dfc8bb1c00bbba4756849b9a09eddc5a7b404 /app-benchmarks
parentapp-benchmarks/interbench: drop 0.31 (diff)
downloadgentoo-16984ec2d2a87b6ccf9db4fb3bd09e291537c707.tar.gz
gentoo-16984ec2d2a87b6ccf9db4fb3bd09e291537c707.tar.bz2
gentoo-16984ec2d2a87b6ccf9db4fb3bd09e291537c707.zip
app-benchmarks/nbench: update EAPI 6 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/nbench/nbench-2.2.3-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-benchmarks/nbench/nbench-2.2.3-r2.ebuild b/app-benchmarks/nbench/nbench-2.2.3-r2.ebuild
new file mode 100644
index 000000000000..3f2f10634e19
--- /dev/null
+++ b/app-benchmarks/nbench/nbench-2.2.3-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${PN}-byte-${PV}"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux/Unix of release 2 of BYTE Magazine's BYTEmark benchmark"
+HOMEPAGE="http://www.tux.org/~mayer/linux/bmark.html"
+SRC_URI="http://www.tux.org/~mayer/linux/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~hppa ~mips ppc ppc64 sparc x86"
+
+PATCHES=( "${FILESDIR}/${P}-Makefile.patch" )
+
+src_prepare() {
+ default
+
+ sed -e 's:$compiler -v\( 2>&1 | sed -e "/version/!d"\|\):$compiler -dumpversion:' \
+ -i sysinfo.sh || die
+
+ sed -e 's:inpath="NNET.DAT":inpath="/usr/share/nbench/NNET.DAT":' \
+ -i nbench1.h || die
+}
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin nbench
+ dodoc Changes README* bdoc.txt
+
+ insinto /usr/share/nbench
+ doins NNET.DAT
+}