summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-10-28 12:03:12 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-28 14:17:14 +0200
commit0d714555c42423bc49ee751e83f8e4e01d69ec45 (patch)
treec43750816481af28335c1705ae0f85cfba2e44a3 /app-crypt/kencfs-plasma
parentprofiles: Fix package.mask message (diff)
downloadgentoo-0d714555c42423bc49ee751e83f8e4e01d69ec45.tar.gz
gentoo-0d714555c42423bc49ee751e83f8e4e01d69ec45.tar.bz2
gentoo-0d714555c42423bc49ee751e83f8e4e01d69ec45.zip
app-crypt/kencfs: pkgmove to app-crypt/kencfs-plasma
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'app-crypt/kencfs-plasma')
-rw-r--r--app-crypt/kencfs-plasma/Manifest1
-rw-r--r--app-crypt/kencfs-plasma/files/kencfs-1.4.0-encfs5.patch13
-rw-r--r--app-crypt/kencfs-plasma/files/kencfs-1.6.2-desktop.patch11
-rw-r--r--app-crypt/kencfs-plasma/kencfs-plasma-1.6.4.ebuild48
4 files changed, 73 insertions, 0 deletions
diff --git a/app-crypt/kencfs-plasma/Manifest b/app-crypt/kencfs-plasma/Manifest
index c37c0e97296d..809497c429fd 100644
--- a/app-crypt/kencfs-plasma/Manifest
+++ b/app-crypt/kencfs-plasma/Manifest
@@ -1 +1,2 @@
+DIST kencfs-1.6.4.tar.gz 221386 SHA256 3e88cd2bf0d11ce83746fb5b1e385f172ed506cde922ee2811f9cdbaaa80c4ca SHA512 44dacd0a17194b61d2d73820851b496d6052dbab3893a030db2e63c1be0d1569d80cc75ce0c179381e98b60c5e27ccead8ee257f53f57dea508808616abb514d WHIRLPOOL 8b7f372c8c8304f3a3249a74a565ea77c4c3f255c6db3cf66a2a62951be1b8010e9696dc5d5ac44ea1e39d189c63e4a1ccf562cd4886578e8a2383756e48d24b
DIST kencfs-plasma-2.0.1a.tar.gz 216580 SHA256 8a46fd2f2f490323350ae17d34d7c10de1afe73943413a3e2cc10e52d3dd6eb6 SHA512 a9093680bb141c18e2d4ed8a966f7176c40c10fa0ee6e5cee25ae26ef3f94e6ffc7e3f0a7b55321640e4ba6e484d75755f901b53688dbfc5c22a1c0b1e01cfac WHIRLPOOL 146aedf68686611be6bbe69c7b9370e27780c7bf33f1ea962c4b48a895770be0b50a03257a8d74b38eef99fbbdfa85a7c116b7f7385b80e343a3063b79f895e6
diff --git a/app-crypt/kencfs-plasma/files/kencfs-1.4.0-encfs5.patch b/app-crypt/kencfs-plasma/files/kencfs-1.4.0-encfs5.patch
new file mode 100644
index 000000000000..6687ac0f1f9b
--- /dev/null
+++ b/app-crypt/kencfs-plasma/files/kencfs-1.4.0-encfs5.patch
@@ -0,0 +1,13 @@
+Support older encfs5 volumes wrt Gentoo bug #446652.
+
+--- a/fsDialog.cpp
++++ b/fsDialog.cpp
+@@ -161,7 +161,7 @@
+
+ arg << cr << pm << "-S";
+ p->start(prg,arg);
+- if (! QFile::exists(cr+"/.encfs6.xml")) p->write("\n");
++ if (! (QFile::exists(cr+"/.encfs6.xml") || QFile::exists(cr+"/.encfs5")) ) p->write("\n");
+ p->write(pw.toLocal8Bit().data());
+ p->write("\n");
+ p->waitForFinished();
diff --git a/app-crypt/kencfs-plasma/files/kencfs-1.6.2-desktop.patch b/app-crypt/kencfs-plasma/files/kencfs-1.6.2-desktop.patch
new file mode 100644
index 000000000000..2d8683f11e46
--- /dev/null
+++ b/app-crypt/kencfs-plasma/files/kencfs-1.6.2-desktop.patch
@@ -0,0 +1,11 @@
+--- a/kencfs.desktop
++++ b/kencfs.desktop
+@@ -2,7 +2,7 @@
+ Name=KEncFS
+ Exec=kencfs
+ Icon=kencfs/kencfs-icon
+-Categories=System;Security
++Categories=Qt;KDE;System;Security;
+ Terminal=false
+ Type=Application
+ StartupNotify=false
diff --git a/app-crypt/kencfs-plasma/kencfs-plasma-1.6.4.ebuild b/app-crypt/kencfs-plasma/kencfs-plasma-1.6.4.ebuild
new file mode 100644
index 000000000000..3661c4b1d3f3
--- /dev/null
+++ b/app-crypt/kencfs-plasma/kencfs-plasma-1.6.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/-plasma/}"
+inherit qmake-utils
+
+DESCRIPTION="GUI frontend for encfs"
+HOMEPAGE="https://www.linux-apps.com/content/show.php?content=134003"
+SRC_URI="https://dl.opendesktop.org/api/files/download/id/1486311191/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ kde-frameworks/kdelibs:4
+"
+RDEPEND="${DEPEND}
+ kde-frameworks/kwallet:5
+ sys-fs/encfs
+"
+
+PATCHES=(
+ "${FILESDIR}/${MY_PN}-1.4.0-encfs5.patch"
+ "${FILESDIR}/${MY_PN}-1.6.2-desktop.patch"
+)
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ default
+
+ sed -i ${MY_PN}.pro -e "/^doc.path =/s/${MY_PN}/${MY_PN}-${PVR}/" \
+ || die "sed docdir failed"
+}
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}