summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-03-05 18:07:25 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2018-03-05 18:07:25 +0200
commitaf4ea715963c943db4fd6ed197f0e0da11587dc9 (patch)
tree7eb7dcb4d134e0bccfbfe45738b8397515404007 /app-crypt/xca
parentsci-mathematics/cgal: Sort DEPENDs, use HTML_DOCS (diff)
downloadgentoo-af4ea715963c943db4fd6ed197f0e0da11587dc9.tar.gz
gentoo-af4ea715963c943db4fd6ed197f0e0da11587dc9.tar.bz2
gentoo-af4ea715963c943db4fd6ed197f0e0da11587dc9.zip
app-crypt/xca: version bump
Closes: https://bugs.gentoo.org/show_bug.cgi?id=649620 Thanks: Polynomial-C Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-crypt/xca')
-rw-r--r--app-crypt/xca/Manifest1
-rw-r--r--app-crypt/xca/xca-1.4.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-crypt/xca/Manifest b/app-crypt/xca/Manifest
index 6926f5b70077..acafec0a9b22 100644
--- a/app-crypt/xca/Manifest
+++ b/app-crypt/xca/Manifest
@@ -1,2 +1,3 @@
DIST xca-1.3.2.tar.gz 897947 BLAKE2B b12cc95c908187d78304ce93111c89bb8e0dc01ecab37e0ad1bd78f84a90ed9f44afa4ac35d22185b7018e238b476e496fca3c2b3a240bf654d2e5160e784b11 SHA512 f0a9c4d47f0c20632f44364cc55293a7d2152772a746a72bc4a46622da4e48ae612bafe918c098a71c29cdfca8e6c03c27cf85a862ca0f356eddf061414c89b2
DIST xca-1.4.0.tar.gz 940245 BLAKE2B 1f0c9d72b647fa803c2b6b6019b0b9828f37b1d38d89838ac6102d560b1c930c0f962e9064d984540b0c8e14d7546529af978673955555283afa1f089af7ce7c SHA512 b220adc7551cf853037c4f5ef0cdd8eef1dda44d0fde634cfde35605396b988452bdbc97a60459911f663d6d6977d426f27f47a46a482d1a30331ac06862c1c9
+DIST xca-1.4.1.tar.gz 959107 BLAKE2B 7437cdbaa5277998de200e9a5ad3a7d44aed9ae8af8fd926d7ed1917d49bec79562455ca2e82557149d748840f299ffd66edfc7f265be7d5bdcd6e4fe8dbaf9b SHA512 8294669c4887ba7a9060c3c2c06014b8a1807898569842ed61c066e8a864de014fba51a2ff867b579048083fdd4934cc7f97c92268de4944bf4aafea9c2e7b42
diff --git a/app-crypt/xca/xca-1.4.1.ebuild b/app-crypt/xca/xca-1.4.1.ebuild
new file mode 100644
index 000000000000..aaaacc6e8049
--- /dev/null
+++ b/app-crypt/xca/xca-1.4.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit xdg-utils
+
+DESCRIPTION="A GUI to OpenSSL, RSA public keys, certificates, signing requests etc"
+HOMEPAGE="http://hohnstaedt.de/xca/"
+SRC_URI="https://github.com/chris2511/${PN}/releases/download/RELEASE.${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="bindist doc libressl"
+
+RDEPEND="
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ !libressl? ( dev-libs/openssl:0=[bindist=] )
+ libressl? ( dev-libs/libressl:0= )
+ doc? ( app-text/linuxdoc-tools )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.0-desktop.patch"
+)
+
+src_configure() {
+ econf \
+ --with-qt-version=5 \
+ $(use_enable doc) \
+ STRIP=true
+}
+
+src_compile() {
+ # enforce all to avoid the automatic silent rules
+ emake all
+}
+
+src_install() {
+ # non standard destdir
+ emake install destdir="${ED}"
+ einstalldocs
+
+ insinto /etc/xca
+ doins misc/*.txt
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}