summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2019-01-31 21:07:37 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2019-01-31 21:19:02 -0500
commit124490558a5478d1c69ac8dd63c6514ec0c4a9d0 (patch)
treebb28fe7f721530efa7c4a38f054472e8041af379 /app-crypt/yubikey-manager-qt
parentapp-crypt/yubikey-manager: bump to 2.0.0 #674050 (diff)
downloadgentoo-124490558a5478d1c69ac8dd63c6514ec0c4a9d0.tar.gz
gentoo-124490558a5478d1c69ac8dd63c6514ec0c4a9d0.tar.bz2
gentoo-124490558a5478d1c69ac8dd63c6514ec0c4a9d0.zip
app-crypt/yubikey-manager-qt: bump to 1.1.0 #674052
Closes: https://bugs.gentoo.org/674052 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'app-crypt/yubikey-manager-qt')
-rw-r--r--app-crypt/yubikey-manager-qt/Manifest1
-rw-r--r--app-crypt/yubikey-manager-qt/yubikey-manager-qt-1.1.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager-qt/Manifest b/app-crypt/yubikey-manager-qt/Manifest
index 5c6c46f7b61b..aeb53deb6ca5 100644
--- a/app-crypt/yubikey-manager-qt/Manifest
+++ b/app-crypt/yubikey-manager-qt/Manifest
@@ -2,3 +2,4 @@ DIST yubikey-manager-qt-0.4.0.tar.gz 183566 BLAKE2B 2364d0d257ab5c05d0555aba4bb0
DIST yubikey-manager-qt-0.5.1.tar 655360 BLAKE2B 6b109190750bd9675e32c836831a7e0ea286021303deffc64a351f2a127f5a5ee0190e3ca99abf0407bbb34a1a1c454f453fab464de2726f6cae539d5f865da1 SHA512 a8ceab5fd8d20eca2424d3f9a92ad12066e8fc26a7640df478965e5d9e2896fbc64885b26f599fcb2588f5b64d2f046af373f87e23ef266178ddf877e422ed36
DIST yubikey-manager-qt-0.5.2.tar.gz 337194 BLAKE2B d6020116b9082671c039b521bbeebe7c1f0be022e233abbf8d6d788ea94e69e5f88aa3d6ec26a7b2edffa698327bb049e83ce54db2e0ba2ed1ad1dd536ab0961 SHA512 29265a10ae1dfe14dfdf4f1ba225516bf3bcbeb0115ca81696a4c5c506e957d6a99b0bb11a608e3175df99b8c04e8ae9250d5d42aab2b44b633d18fd2fc4c227
DIST yubikey-manager-qt-1.0.0.tar.gz 8038084 BLAKE2B 9e1082be62dab2d43bfad3050dd38dbcd10e5b8761bf567ba4f3e1b4627a25709cfa29ac7a23560fff76e0a75b4668932a407268c8d90d791c381ad485fea029 SHA512 2cf5f70b2734a7c0346649f5419dbee39bef9bb80bb498631d4879abc48d422d70468713a48945e284f2bdef20f3bb570a0ac5a4daab6c1ff195d86e39168843
+DIST yubikey-manager-qt-1.1.0.tar.gz 10893455 BLAKE2B d83f76b83f35380377beb0e5c5b4a605049211685ff3ec44f60c909f8bc8f60dcd0868ad666bebce13e7c0459f604dd5d77cb1bd01035fe8584c019aacca39e8 SHA512 b54f1e6908b190ccb9273b906ace9ce2e1d189b794ba9b0ae00dbda4808b3f376b37c5f010ae06eaa63515af9b48698499f87780c59394f8b80f35d64d599c59
diff --git a/app-crypt/yubikey-manager-qt/yubikey-manager-qt-1.1.0.ebuild b/app-crypt/yubikey-manager-qt/yubikey-manager-qt-1.1.0.ebuild
new file mode 100644
index 000000000000..54eda43c3b07
--- /dev/null
+++ b/app-crypt/yubikey-manager-qt/yubikey-manager-qt-1.1.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit eutils qmake-utils python-single-r1
+
+DESCRIPTION="Cross-platform application for configuring any YubiKey over all USB transports"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager-qt https://github.com/Yubico/yubikey-manager-qt"
+SRC_URI="https://github.com/Yubico/${PN}/archive/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=app-crypt/yubikey-manager-1.0.0[${PYTHON_USEDEP}]
+ <app-crypt/yubikey-manager-3.0.0[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyotherside[${PYTHON_USEDEP}]
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgraphicaleffects:5
+ dev-qt/qtgui:5
+ dev-qt/qtquickcontrols:5[widgets]
+ dev-qt/qtquickcontrols2:5[widgets]
+ dev-qt/qtsingleapplication[qt5(+),X]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_prepare() {
+ default
+
+ sed -i -e "s/ykman-cli//" ${PN}.pro || die
+ sed -e "/CONFIG += c++11/a CONFIG += qtsingleapplication" \
+ -i ykman-gui/ykman-gui.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ domenu resources/ykman-gui.desktop
+ doicon -s 128 resources/icons/ykman.png
+ doicon -s scalable resources/icons/ykman.svg
+
+ einstalldocs
+}