summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2016-06-20 12:37:54 +0300
committerGöktürk Yüksek <gokturk@gentoo.org>2016-06-22 00:08:00 -0400
commitb444ce69ac0d80d15abbb8851e421c6e4ed600c1 (patch)
treea00319098b858e8f7719209d0b4ddb48177135d2 /app-editors
parentapp-editors/kakoune: fix a linking bug (diff)
downloadgentoo-b444ce69ac0d80d15abbb8851e421c6e4ed600c1.tar.gz
gentoo-b444ce69ac0d80d15abbb8851e421c6e4ed600c1.tar.bz2
gentoo-b444ce69ac0d80d15abbb8851e421c6e4ed600c1.zip
app-editors/kakoune: bump to 0_pre20160620
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/kakoune/Manifest1
-rw-r--r--app-editors/kakoune/kakoune-0_pre20160620.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-editors/kakoune/Manifest b/app-editors/kakoune/Manifest
index a6d34fa9c09e..a70bcb166064 100644
--- a/app-editors/kakoune/Manifest
+++ b/app-editors/kakoune/Manifest
@@ -1 +1,2 @@
DIST kakoune-0_pre20160515.tar.gz 369625 SHA256 e826e9225ca2ac13d4b0b5587481aaf59dc2421d93f376b21056199c4f8df9bc SHA512 09651fe485c55c35b878d14044cef565fd5c38c91e658181e051d0034886b30f8dc53a33c79f2d28bb64f51719c4d688a91978020308b01e8a6663eb2b556954 WHIRLPOOL dc403e37399850508135e9a584cc4e49dd7d52b7c573f28cff3346a5c8cca4821361b71da62312bf4d13fe09b7e43c94888159d96fc13cb788ba902353121417
+DIST kakoune-0_pre20160620.tar.gz 370523 SHA256 4344bc78a15942c01818c8e8a80f228249557f5d2d20c2fdc845faeef86abe2e SHA512 c186b9024db7956d9bcae925727c3f30dd2c2fb49995e97c56dbdf59c3f17989feb405086957818685a08530da0f2b58b5798687959267da7e9e2a25dd78003c WHIRLPOOL c555754e4fc3456ce7912d60adb72191349692d0465996893ceb1162cc5f7f61b08b0098f13a54d5d44c861aaf3b23eaea343813f055b8ca06f6ce1305a30f4d
diff --git a/app-editors/kakoune/kakoune-0_pre20160620.ebuild b/app-editors/kakoune/kakoune-0_pre20160620.ebuild
new file mode 100644
index 000000000000..a86f8db47759
--- /dev/null
+++ b/app-editors/kakoune/kakoune-0_pre20160620.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs vcs-snapshot
+
+REF="34c8e6a9cf15410a433c8a8c3901703708b85611"
+
+DESCRIPTION="Selection-oriented code editor inspired by vim"
+HOMEPAGE="https://github.com/mawww/kakoune"
+SRC_URI="https://github.com/mawww/${PN}/tarball/${REF} -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ sys-libs/ncurses:=[unicode]
+ dev-libs/boost
+"
+DEPEND="
+ app-text/asciidoc
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )
+
+src_configure() {
+ append-cppflags $(pkg-config --cflags ncursesw)
+ append-libs $(pkg-config --libs ncursesw)
+ export CXX=$(tc-getCXX)
+ export debug=$(usex debug)
+ S="${WORKDIR}/${P}/src"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" docdir="${D}/usr/share/doc/${PF}" install
+}