summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-08-10 17:46:18 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-08-10 20:16:35 +0200
commit250420c025ca376cf03f80754bfe8144081f3cbb (patch)
tree93d4a21bd7d7d955a1d54fe3b7f53dd55b8d71bf /app-emacs/with-editor
parentapp-emacs/with-editor: drop old 3.3.3 (diff)
downloadgentoo-250420c025ca376cf03f80754bfe8144081f3cbb.tar.gz
gentoo-250420c025ca376cf03f80754bfe8144081f3cbb.tar.bz2
gentoo-250420c025ca376cf03f80754bfe8144081f3cbb.zip
app-emacs/with-editor: bump to 3.4.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/with-editor')
-rw-r--r--app-emacs/with-editor/Manifest1
-rw-r--r--app-emacs/with-editor/with-editor-3.4.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/with-editor/Manifest b/app-emacs/with-editor/Manifest
index 7e3f33dfea1a..d690bd9f7b0e 100644
--- a/app-emacs/with-editor/Manifest
+++ b/app-emacs/with-editor/Manifest
@@ -1,2 +1,3 @@
DIST with-editor-3.3.4.tar.gz 33288 BLAKE2B 59e2b1c94be967cafbe112aad34a51aef6355d2f734ee2ce6160d3de2357fef226ef7bb0666f3c419b9e1bdce0ab8e3468ab0ab9bc259152014ede7ed1b4b453 SHA512 700f6e5a884e4664b2450f7dd3ea879f45934abdbc09eb9569a58233d57ad7411a47d977341231b5c23a2ae5710ce490b2ee3960aee150e912a3ec0017665942
DIST with-editor-3.4.0.tar.gz 33396 BLAKE2B bc5956e658e77fcc4bdc2099374299fe38696d200ad201f9be1a63039874f7e33b035b91cd54a7a7abbbf9855bc47d775db85713bea003fb4d780e0c2266129a SHA512 c1ad247d1cc90fe5f5ace0ca257f33751d1e8eee7cd7b11bdfba6ead7a82a47be59b1cc8f3bcb28b77b5a386ee1604ef27ca72d5ced3d8a2262b298f85a8b1ee
+DIST with-editor-3.4.1.tar.gz 33395 BLAKE2B 5d71328f455b87bd6af60ce1a6f07c39b16619fd4d8232e6a38761b60daa40786999e36a3a3c46687e59a84e2f23ac89b51bcf43e45da7bdc1c61aac12480ddf SHA512 1cca1803355461fac83107d40661edb8e6ee4fd6e5f925b80ffd28dfb6ee97387f1d18336b58c467f19b5e5d8b55ef162274840d0daaedb728594966cbc86120
diff --git a/app-emacs/with-editor/with-editor-3.4.1.ebuild b/app-emacs/with-editor/with-editor-3.4.1.ebuild
new file mode 100644
index 000000000000..f01c1a6f71dd
--- /dev/null
+++ b/app-emacs/with-editor/with-editor-3.4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Use the Emacsclient as the \$EDITOR of child processes"
+HOMEPAGE="https://magit.vc/manual/with-editor/
+ https://github.com/magit/with-editor/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+S="${WORKDIR}/${P}/lisp"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.0.0
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+DOCS=( ../README.org ../docs/${PN}.org )
+ELISP_TEXINFO="../docs/*.texi"
+SITEFILE="50${PN}-gentoo.el"