summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Turner <jturner.usa@gmail.com>2022-10-26 23:35:17 -0400
committerMaciej Barć <xgqt@gentoo.org>2022-10-27 06:17:39 +0200
commit3e400659ac2eabef91a77fd2dc17ef3b836d9977 (patch)
treed478ac30f11a556dc2e4962e0c50599111ae75d0 /app-emacs
parentdev-python/scipy: switch to python_configure_all (diff)
downloadgentoo-3e400659ac2eabef91a77fd2dc17ef3b836d9977.tar.gz
gentoo-3e400659ac2eabef91a77fd2dc17ef3b836d9977.tar.bz2
gentoo-3e400659ac2eabef91a77fd2dc17ef3b836d9977.zip
app-emacs/projectile: add 2.6.0
Signed-off-by: John Turner <jturner.usa@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/27970 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/projectile/Manifest1
-rw-r--r--app-emacs/projectile/projectile-2.6.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/projectile/Manifest b/app-emacs/projectile/Manifest
index 1a31170312ff..c5d77d6aa606 100644
--- a/app-emacs/projectile/Manifest
+++ b/app-emacs/projectile/Manifest
@@ -1 +1,2 @@
DIST projectile-2.5.0.tar.gz 1915860 BLAKE2B 4d215e2c1e44c7f85121fc36445112f3064129fe95866b4fbb2e14b11d31519057d9cc69bcdf44c82cd516768cc73a031da48a7c5352b9825816db54810cafcb SHA512 3faeb7db70e5e2198ad307c1d5d24a5fadd207765387e7094691e40071411506e6df690995f923bf246b7176173ca41882d369276862b631d7436747bfeae3a3
+DIST projectile-2.6.0.tar.gz 1922935 BLAKE2B 40e5fc3d152b4fa244bb42cd606d4d6c92e9a212a3d58b7e5e3b333a6b9eb07ca05d61c18aa1859ba5e99872c92f2b8ae11442e5ebda22b057cb49017b1deff8 SHA512 28898d8e48c1dc90ada0f3648e8ef96bff96a3873af61d7f454160fa9fb5f2e8b08c7e0ab99953170b252a29bc04ccb3c10803807b0b96cfcead167855642fed
diff --git a/app-emacs/projectile/projectile-2.6.0.ebuild b/app-emacs/projectile/projectile-2.6.0.ebuild
new file mode 100644
index 000000000000..26f4e8b00c5e
--- /dev/null
+++ b/app-emacs/projectile/projectile-2.6.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="25.1"
+
+inherit elisp
+
+DESCRIPTION="A project interaction library for Emacs"
+HOMEPAGE="https://docs.projectile.mx"
+SRC_URI="https://github.com/bbatsov/projectile/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/buttercup )"
+
+SITEFILE="50projectile-gentoo.el"
+DOCS=( README.md )
+
+src_test() {
+ mkdir -p "${HOME}"/.emacs.d || die # For "projectile--directory-p" test
+ buttercup -L . -L test --traceback full || die
+}