summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-05-28 17:02:39 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-05-28 17:13:12 +0200
commitb18d20f7f7ad64e25df59e25c018c52fc590d2da (patch)
tree3fc7eb62c1feb302e968f14ed98a6b9d1e1bfcc2 /app-emacs
parentdev-lang/eisl: drop old 2.96 (diff)
downloadgentoo-b18d20f7f7ad64e25df59e25c018c52fc590d2da.tar.gz
gentoo-b18d20f7f7ad64e25df59e25c018c52fc590d2da.tar.bz2
gentoo-b18d20f7f7ad64e25df59e25c018c52fc590d2da.zip
app-emacs/magit: add live version
Closes: https://bugs.gentoo.org/907297 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/magit/magit-9999.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-emacs/magit/magit-9999.ebuild b/app-emacs/magit/magit-9999.ebuild
new file mode 100644
index 000000000000..031034b86493
--- /dev/null
+++ b/app-emacs/magit/magit-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="A Git porcelain inside Emacs"
+HOMEPAGE="https://magit.vc/
+ https://github.com/magit/magit/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/magit/magit.git"
+else
+ SRC_URI="https://github.com/magit/magit/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+S="${S}/lisp"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( ../README.md ../docs/AUTHORS.md ../docs/RelNotes )
+ELISP_TEXINFO="../docs/*.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/dash-2.19.1
+ >=app-emacs/transient-0.3.6
+ >=app-emacs/with-editor-3.0.5
+ app-emacs/libegit2
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+RDEPEND+="
+ >=dev-vcs/git-2.0.0
+"
+
+src_prepare() {
+ default
+
+ echo "(setq magit-version \"${PV}\")" > magit-version.el || die
+}