summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-06-02 00:44:17 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-06-02 02:53:34 -0400
commite21edcd77f0cb9f9a6d48605ba19df97f6b90c04 (patch)
treef5ec6411542ade3ad4e261393be0dc8db8fb235b /app-emulation
parentapp-emulation/wine-proton: USE=-debug -> global USE=strip in live (diff)
downloadgentoo-e21edcd77f0cb9f9a6d48605ba19df97f6b90c04.tar.gz
gentoo-e21edcd77f0cb9f9a6d48605ba19df97f6b90c04.tar.bz2
gentoo-e21edcd77f0cb9f9a6d48605ba19df97f6b90c04.zip
app-emulation/wine-staging: USE=-debug -> global USE=strip in live
Will update the old ebuilds eventually but given this triggers a rebuild with --changed-use (default enabled), will wait till a few bumps and maybe stable to give a chance for people to update and depclean old rather than unnecessarily rebuild all. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-staging/wine-staging-9999.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/app-emulation/wine-staging/wine-staging-9999.ebuild b/app-emulation/wine-staging/wine-staging-9999.ebuild
index 91fff75c3a4c..767e89f5480c 100644
--- a/app-emulation/wine-staging/wine-staging-9999.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9999.ebuild
@@ -34,9 +34,9 @@ LICENSE="LGPL-2.1+ BSD-2 IJG MIT OPENLDAP ZLIB gsm libpng2 libtiff"
SLOT="${PV}"
IUSE="
+X +abi_x86_32 +abi_x86_64 +alsa capi crossdev-mingw cups dos
- llvm-libunwind debug custom-cflags +fontconfig +gecko gphoto2
- +gstreamer kerberos +mingw +mono netapi nls opencl +opengl osmesa
- pcap perl pulseaudio samba scanner +sdl selinux smartcard +ssl
+ llvm-libunwind custom-cflags +fontconfig +gecko gphoto2 +gstreamer
+ kerberos +mingw +mono netapi nls opencl +opengl osmesa pcap perl
+ pulseaudio samba scanner +sdl selinux smartcard +ssl +strip
+truetype udev udisks +unwind usb v4l +vulkan wayland +xcomposite
xinerama"
REQUIRED_USE="
@@ -356,13 +356,17 @@ src_install() {
make_wrapper "${bin##*/}-${P#wine-}" "${bin#"${ED}"}"
done
- # don't let portage try to strip PE files with the wrong
- # strip executable and instead handle it here (saves ~120MB)
if use mingw; then
+ # don't let portage try to strip PE files with the wrong
+ # strip executable and instead handle it here (saves ~120MB)
dostrip -x ${WINE_PREFIX}/wine/{i386,x86_64}-windows
- use debug ||
+
+ if use strip; then
+ ebegin "Stripping Windows (PE) binaries"
find "${ED}"${WINE_PREFIX}/wine/*-windows -regex '.*\.\(a\|dll\|exe\)' \
- -exec $(usex abi_x86_64 x86_64 i686)-w64-mingw32-strip --strip-unneeded {} + || die
+ -exec $(usex abi_x86_64 x86_64 i686)-w64-mingw32-strip --strip-unneeded {} +
+ eend ${?} || die
+ fi
fi
dodoc ANNOUNCE AUTHORS README* documentation/README*