summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2017-03-06 14:10:09 +0100
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2017-03-06 14:10:09 +0100
commit82c3d61152a5527a0f68869918c92ee2d0e46b51 (patch)
tree3c08c9a60a67f186572db8427ff1371206e86785 /app-forensics/volatility
parentnet-fs/cifs-utils: Removed old. (diff)
downloadgentoo-82c3d61152a5527a0f68869918c92ee2d0e46b51.tar.gz
gentoo-82c3d61152a5527a0f68869918c92ee2d0e46b51.tar.bz2
gentoo-82c3d61152a5527a0f68869918c92ee2d0e46b51.zip
app-forensics/volatility: version bump, allow building against pycryptodome
Bug: https://bugs.gentoo.org/show_bug.cgi?id=599056 Bug: https://bugs.gentoo.org/show_bug.cgi?id=611582 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-forensics/volatility')
-rw-r--r--app-forensics/volatility/Manifest1
-rw-r--r--app-forensics/volatility/volatility-2.6.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-forensics/volatility/Manifest b/app-forensics/volatility/Manifest
index 95762a7624c2..29215a9fbc61 100644
--- a/app-forensics/volatility/Manifest
+++ b/app-forensics/volatility/Manifest
@@ -1 +1,2 @@
DIST volatility-2.4.1.tar.gz 2407119 SHA256 43d2946ec9c198a028fc068e8b4add7836ca03482665bacdd31998bc540e5c9c SHA512 cc2db2a17b071a21852bab967c9615df0fce369dac35ffbca8754bc789e218a86fc88bd2042203174308e620e281a24debc7b0a8bacd516a404a9170ea522596 WHIRLPOOL 386adfe0750a8b21656d95fb5a8fb9276b1199e94099e74f66d76cbdc0191de92449b93e708140e94072a136488235fd9f0515b14752bc7c2c97fdf81ec02220
+DIST volatility-2.6.zip 4179806 SHA256 5b73050d72bf94870ffce22843f03d4b0b7764011dec29ef1a0a5b1b46cf9295 SHA512 1c0b86f270188ba48a6a0ff1d7ad70bde500d0f720d7e1b9d76b6b9498368ae3eb29c5b1c7e7dd76ec9480b83b1e484b4130b4ced7458e4e03ca61fe7d13220f WHIRLPOOL b3432b0725f49c132029102d1f7ba099dffc6c4339ccb5bfaf108d3cf67e3ceb7b221b8e00cc641941af189b74991a51c3fb109819ff8abeb9e8414a49cac6f8
diff --git a/app-forensics/volatility/volatility-2.6.ebuild b/app-forensics/volatility/volatility-2.6.ebuild
new file mode 100644
index 000000000000..c2c54c4fce8d
--- /dev/null
+++ b/app-forensics/volatility/volatility-2.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="Framework for analyzing volatile memory"
+HOMEPAGE="http://www.volatilityfoundation.org/"
+SRC_URI="http://downloads.volatilityfoundation.org/releases/${PV}/${P}.zip"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}-master
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=dev-libs/distorm64-3[${PYTHON_USEDEP}]
+ dev-libs/libpcre
+ || (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )"
+
+src_install() {
+ distutils-r1_src_install
+ mkdir "${D}/usr/share/${PN}"
+ mv "${D}/usr/contrib/plugins" "${D}/usr/share/${PN}/"
+ rmdir "${D}/usr/contrib"
+ mv "${D}/usr/tools" "${D}/usr/share/${PN}/"
+ dosym /usr/bin/vol.py /usr/bin/volatility
+}