summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYongxiang Liang <tanekliang@gmail.com>2023-12-06 13:56:10 +0800
committerYixun Lan <dlan@gentoo.org>2023-12-25 11:50:44 +0000
commit3e2b4494511c68f48ca9319680e8bce05c374b42 (patch)
tree963f7b77c458cccb288a0bd4ff511b8ab515d827 /app-i18n
parentprofiles/base: Default to lua-5.4 for app-i18n/fcitx-lua (diff)
downloadgentoo-3e2b4494511c68f48ca9319680e8bce05c374b42.tar.gz
gentoo-3e2b4494511c68f48ca9319680e8bce05c374b42.tar.bz2
gentoo-3e2b4494511c68f48ca9319680e8bce05c374b42.zip
app-i18n/fcitx-chinese-addons: new package, add 5.1.2
fcitx-chinese-addons are Chinese related addons for fcitx5. It provides pinyin and table input method support. Bug: https://bugs.gentoo.org/760501 Signed-off-by: Yongxiang Liang <tanekliang@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/fcitx-chinese-addons/Manifest1
-rw-r--r--app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.2.ebuild57
-rw-r--r--app-i18n/fcitx-chinese-addons/metadata.xml26
3 files changed, 84 insertions, 0 deletions
diff --git a/app-i18n/fcitx-chinese-addons/Manifest b/app-i18n/fcitx-chinese-addons/Manifest
new file mode 100644
index 000000000000..e044fd5b8310
--- /dev/null
+++ b/app-i18n/fcitx-chinese-addons/Manifest
@@ -0,0 +1 @@
+DIST fcitx5-chinese-addons-5.1.2_dict.tar.xz 883388 BLAKE2B 7db9fcd8b9fddce9db5b0cf23e5300d7a246183184c32d8292a92617f5b66bebd81a5876cb197508676266c39fbeae5a17fd659feadab0a41be1df948c9663fe SHA512 8a94b974b461dc0a20ee7c243d482295359be27a7cc2152755aebdde3330a62f579506666e231d15cd081e58794359f1791b674f8d9f873babf7c68f4dea81a1
diff --git a/app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.2.ebuild b/app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.2.ebuild
new file mode 100644
index 000000000000..64a5b3a5b44e
--- /dev/null
+++ b/app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="fcitx5-chinese-addons"
+
+inherit cmake xdg
+
+DESCRIPTION="Addons related to Chinese, including IME previous bundled inside fcitx4."
+HOMEPAGE="https://github.com/fcitx/fcitx5-chinese-addons"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}_dict.tar.xz"
+
+LICENSE="GPL-2+ LGPL-2+"
+KEYWORDS="~amd64 ~x86"
+SLOT="5"
+IUSE="+gui webengine +cloudpinyin +qt5 lua +opencc test"
+REQUIRED_USE="
+ gui? ( qt5 )
+ webengine? ( gui )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-i18n/fcitx-5.1.5:5
+ >=app-i18n/libime-1.1.3:5
+ >=dev-libs/boost-1.61:=
+ cloudpinyin? ( net-misc/curl )
+ lua? ( app-i18n/fcitx-lua:5 )
+ opencc? ( app-i18n/opencc:= )
+ gui? (
+ qt5? (
+ dev-qt/qtconcurrent:5
+ app-i18n/fcitx-qt:5[qt5,-onlyplugin]
+ webengine? ( dev-qt/qtwebengine:5[widgets] )
+ )
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_BROWSER=$(usex webengine)
+ -DENABLE_CLOUDPINYIN=$(usex cloudpinyin)
+ -DENABLE_GUI=$(usex gui)
+ -DENABLE_OPENCC=$(usex opencc)
+ -DENABLE_TEST=$(usex test)
+ -DUSE_WEBKIT=no
+ )
+ cmake_src_configure
+}
diff --git a/app-i18n/fcitx-chinese-addons/metadata.xml b/app-i18n/fcitx-chinese-addons/metadata.xml
new file mode 100644
index 000000000000..c73b7e1cf220
--- /dev/null
+++ b/app-i18n/fcitx-chinese-addons/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>tanekliang@gmail.com</email>
+ <name>Yongxiang Liang</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <use>
+ <flag name="cloudpinyin">Build cloud pinyin addon</flag>
+ <flag name="gui">Enable GUI support (qt5 or qt6)</flag>
+ <flag name="opencc">Enable support for conversion between Traditional and Simplified Chinese</flag>
+ <flag name="qt5">Enable configure qt5</flag>
+ <flag name="webengine">Enable built-in browser using <pkg>dev-qt/qtwebengine</pkg></flag>
+ </use>
+<upstream>
+<remote-id type="github">fcitx/fcitx5-chinese-addons</remote-id>
+</upstream>
+</pkgmetadata>