summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-office/impressive
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-office/impressive')
-rw-r--r--app-office/impressive/Manifest2
-rw-r--r--app-office/impressive/files/impressive-pillow.patch15
-rw-r--r--app-office/impressive/impressive-0.10.5.ebuild47
-rw-r--r--app-office/impressive/impressive-0.11.0b.ebuild59
-rw-r--r--app-office/impressive/metadata.xml8
5 files changed, 131 insertions, 0 deletions
diff --git a/app-office/impressive/Manifest b/app-office/impressive/Manifest
new file mode 100644
index 000000000000..7388745f70d9
--- /dev/null
+++ b/app-office/impressive/Manifest
@@ -0,0 +1,2 @@
+DIST Impressive-0.10.5.tar.gz 166707 SHA256 55f1f2021c7bcbdd147f44ec7418125c114dfcd606583ecab34a3adaa1fae13b SHA512 3939188d45ac7a617a56be72e72c98923c23073bee2c3c1b7b81fc2e26ce415ceffdf5456d754f921e488181d8edb7df96ad90e6923b2425c49e38da75c02f20 WHIRLPOOL cff1b609e9e722f621ecf5da0ccaee9f2b0d17d22064486f80cfb74ff569f802c3710c7ec1a7e02c6861246d8fa63b51c5468fc5eec0cf9597cdc0ca7ddcabbd
+DIST Impressive-0.11.0b.tar.gz 195138 SHA256 a96735cbd5f0c36dd9e499c068b3a991a852fda71b73acd36da6b764ea198ad9 SHA512 c4038ed7b71ac79078922ee0e24ce3bef4b0384d8d468291f0283266fe8a849825f5798ec1260e40ac12659a8a7cf5325e3aca0e2475b1c483d3ce830f4bc70f WHIRLPOOL e89a979b20aa765e68e433d953f6d5e0a41464a8ee1474213f376d3294ccd0a54e649546316facaa89499bd865addb1ab0706d39b227dcfdcc608c367b8fbdf7
diff --git a/app-office/impressive/files/impressive-pillow.patch b/app-office/impressive/files/impressive-pillow.patch
new file mode 100644
index 000000000000..1b7a1be76f74
--- /dev/null
+++ b/app-office/impressive/files/impressive-pillow.patch
@@ -0,0 +1,15 @@
+# See revision 53 in upstream svn
+# https://bugs.gentoo.org/show_bug.cgi?id=471496
+--- a/impressive.py
++++ b/impressive.py
+@@ -182,8 +182,8 @@
+ from OpenGL.GL import *
+ import pygame
+ from pygame.locals import *
+- import Image, ImageDraw, ImageFont, ImageFilter
+- import TiffImagePlugin, BmpImagePlugin, JpegImagePlugin, PngImagePlugin, PpmImagePlugin
++ from PIL import Image, ImageDraw, ImageFont, ImageFilter
++ from PIL import TiffImagePlugin, BmpImagePlugin, JpegImagePlugin, PngImagePlugin, PpmImagePlugin
+ except (ValueError, ImportError), err:
+ print >>sys.stderr, "Oops! Cannot load necessary modules:", err
+ print >>sys.stderr, """To use Impressive, you need to install the following Python modules:
diff --git a/app-office/impressive/impressive-0.10.5.ebuild b/app-office/impressive/impressive-0.10.5.ebuild
new file mode 100644
index 000000000000..f72ffa52819c
--- /dev/null
+++ b/app-office/impressive/impressive-0.10.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-r1
+
+MY_PN="Impressive"
+
+DESCRIPTION="Stylish way of giving presentations with Python"
+HOMEPAGE="http://impressive.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}/${PV}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}
+ app-text/pdftk
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ x11-misc/xdg-utils
+ x11-apps/xrandr
+ app-text/ghostscript-gpl
+ || ( media-fonts/dejavu media-fonts/corefonts )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_install() {
+ python_foreach_impl python_doscript ${PN}.py
+
+ # compatibility symlinks
+ dosym impressive.py /usr/bin/impressive
+ dosym impressive.py /usr/bin/keyjnote
+
+ # docs
+ doman impressive.1
+ dohtml impressive.html
+ dodoc changelog.txt demo.pdf
+}
diff --git a/app-office/impressive/impressive-0.11.0b.ebuild b/app-office/impressive/impressive-0.11.0b.ebuild
new file mode 100644
index 000000000000..0f79ef3f6ae8
--- /dev/null
+++ b/app-office/impressive/impressive-0.11.0b.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-r1
+
+MY_PN="Impressive"
+
+DESCRIPTION="Stylish way of giving presentations with Python"
+HOMEPAGE="http://impressive.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}/${PV%b}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}
+ app-text/pdftk
+ dev-python/pygame[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ x11-apps/xrandr
+ || (
+ app-text/mupdf
+ app-text/poppler
+ app-text/ghostscript-gpl
+ )
+ || ( media-fonts/dejavu media-fonts/corefonts )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_install() {
+ python_foreach_impl python_doscript ${PN}.py
+
+ # compatibility symlinks
+ dosym impressive.py /usr/bin/impressive
+ dosym impressive.py /usr/bin/keyjnote
+
+ # docs
+ doman impressive.1
+ dohtml impressive.html
+ dodoc changelog.txt demo.pdf
+}
+
+pkg_postinst() {
+ elog "The experience with ${PN} can be enhanced by folowing packages:"
+ optfeature "Starting web or e-mail hyperlinks from PDF documents" x11-misc/xdg-utils
+ optfeature "Sound and video playback" media-video/mplayer
+ optfeature "Sound and video playback" media-video/mplayer2
+ optfeature "Alternate PDF rendering" app-text/mupdf
+ optfeature "Alternate PDF rendering" app-text/poppler
+ optfeature "Alternate PDF rendering" app-text/ghostscript-gpl
+}
diff --git a/app-office/impressive/metadata.xml b/app-office/impressive/metadata.xml
new file mode 100644
index 000000000000..0321bffa6d51
--- /dev/null
+++ b/app-office/impressive/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <upstream>
+ <remote-id type="sourceforge">impressive</remote-id>
+ </upstream>
+</pkgmetadata>