summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-06-25 19:38:17 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-06-25 19:38:28 +0300
commitdab61bb03336f1018b43614185cc8b1dca0922c1 (patch)
treef9726a31a6789b1adab602ac6f5c58dcd4641304 /app-shells
parentwww-client/qutebrowser: add 3.2.1 (diff)
downloadgentoo-dab61bb03336f1018b43614185cc8b1dca0922c1.tar.gz
gentoo-dab61bb03336f1018b43614185cc8b1dca0922c1.tar.bz2
gentoo-dab61bb03336f1018b43614185cc8b1dca0922c1.zip
app-shells/gentoo-bashcomp: add 20240625
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/gentoo-bashcomp/Manifest1
-rw-r--r--app-shells/gentoo-bashcomp/gentoo-bashcomp-20240625.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/app-shells/gentoo-bashcomp/Manifest b/app-shells/gentoo-bashcomp/Manifest
index 9063a5817418..6f130a9a3a5a 100644
--- a/app-shells/gentoo-bashcomp/Manifest
+++ b/app-shells/gentoo-bashcomp/Manifest
@@ -1,2 +1,3 @@
DIST gentoo-bashcomp-20240511.tar.bz2 21695 BLAKE2B 886a80eafbb923b5ccb5c9e6e0749b66878003d99e0ddf8fc3d07c072fd23cb3277eb254c4687695459fe8401d427dee2779bc29f2a48ab1c6f2b4bfe7d4ef0d SHA512 3e5add581268e7911eb18d1958e4db3b549b2afc496231dcf537abe5409fdd4fa045c6f61538be6c2686888e20ad0d0b714ecf82639a9ae0ec6eecedc378b78d
DIST gentoo-bashcomp-20240525.tar.bz2 23392 BLAKE2B 03da7f6a077382efaac9c9ddad2ef6bcf21704574378a400aeeb0ec2b88934c3aac10009912ad6f0d06ae410c42d6013acaf4629f3c6f46abb19b0d1e000c1d9 SHA512 5017f2e106e2b3f1335f1edbce7ede1fd918bd701a1082ec8cd71f1cedad9480109d82381d56587cb6da4dd04c210f9f51dbaaf8b2aa419abbc6fab73825226a
+DIST gentoo-bashcomp-20240625.tar.bz2 23794 BLAKE2B 567131238e24744a5083ad8ec484d4342b6891e95b999d11d809da769d8f2ad3536f7da769f0d291663b9c3be46fe67d261cbdcf59a0f846e4f08a66b4106571 SHA512 1b5476ba7cb1b7c2f1d51c03d592245718fb4c2c07ff5171aee1bfa0def2a2f0bbff7a38950d18e3646285e7432cedee0ee75eed1c6348946793f011de4ddcbf
diff --git a/app-shells/gentoo-bashcomp/gentoo-bashcomp-20240625.ebuild b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20240625.ebuild
new file mode 100644
index 000000000000..f6df12534742
--- /dev/null
+++ b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20240625.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="Gentoo-specific bash command-line completions (emerge, ebuild, equery, etc)"
+HOMEPAGE="https://gitweb.gentoo.org/proj/gentoo-bashcomp.git/"
+SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+src_install() {
+ emake DESTDIR="${D}" install \
+ completionsdir="$(get_bashcompdir)" \
+ helpersdir="$(get_bashhelpersdir)" \
+ compatdir="${EPREFIX}/etc/bash_completion.d"
+}