summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-12-12 19:33:14 -0500
committerAaron Bauman <bman@gentoo.org>2019-12-12 19:33:31 -0500
commitdb87ce464ab36dd3ab2f5643ad51d6378f242425 (patch)
tree1a79c3c67ed04afe57544f98a548538847902924 /app-shells
parentgames-server/minecraft-server: bump to version 1.15.0 (diff)
downloadgentoo-db87ce464ab36dd3ab2f5643ad51d6378f242425.tar.gz
gentoo-db87ce464ab36dd3ab2f5643ad51d6378f242425.tar.bz2
gentoo-db87ce464ab36dd3ab2f5643ad51d6378f242425.zip
app-shells/sash: port to EAPI 7
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/sash/sash-3.8.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/app-shells/sash/sash-3.8.ebuild b/app-shells/sash/sash-3.8.ebuild
index 6c2ee580ce04..e584cdbcd922 100644
--- a/app-shells/sash/sash-3.8.ebuild
+++ b/app-shells/sash/sash-3.8.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit eutils toolchain-funcs flag-o-matic
+inherit toolchain-funcs flag-o-matic
DESCRIPTION="A small (static) UNIX Shell"
-HOMEPAGE="http://www.canb.auug.org.au/~dbell/"
-SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz"
+HOMEPAGE="https://www.canb.auug.org.au/~dbell/"
+SRC_URI="https://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz"
LICENSE="freedist"
SLOT="0"
@@ -20,7 +20,7 @@ DEPEND="
RDEPEND="!static? ( ${DEPEND} )"
src_prepare() {
- epatch "${FILESDIR}"/sash-3.7-builtin.patch
+ eapply "${FILESDIR}"/sash-3.7-builtin.patch
sed \
-e "s:-O3:${CFLAGS}:" \
@@ -29,6 +29,7 @@ src_prepare() {
sed \
-e 's:linux/ext2_fs.h:ext2fs/ext2_fs.h:g' \
-i cmd_chattr.c || die
+ eapply_user
}
src_compile() {
@@ -38,7 +39,6 @@ src_compile() {
}
src_install() {
- into /
dobin sash
doman sash.1
dodoc README