summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/cutemarked
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/cutemarked')
-rw-r--r--app-text/cutemarked/Manifest1
-rw-r--r--app-text/cutemarked/cutemarked-0.11.1.ebuild34
-rw-r--r--app-text/cutemarked/files/cutemarked-0.11.1-respect-destdir.patch24
-rw-r--r--app-text/cutemarked/metadata.xml11
4 files changed, 70 insertions, 0 deletions
diff --git a/app-text/cutemarked/Manifest b/app-text/cutemarked/Manifest
new file mode 100644
index 000000000000..144f8a871779
--- /dev/null
+++ b/app-text/cutemarked/Manifest
@@ -0,0 +1 @@
+DIST cutemarked-0.11.1.tar.gz 759181 SHA256 17f376429bafbd4009099340e71481075f2695a020a7c85a5f91145e168728e8 SHA512 22e1e7825ed0cfbb0480cd73988879dbb89aaf4c6662771e8bd7f5465ceb42cba65f7fa56f114d3b8855ca18f45ee268db4fea94bc92e97195de4e53b9a75139 WHIRLPOOL 99821a99fa3d47ea04f48277b3b35a6211bc772153161b88acecf931bea1e00ba433a2b0ddabb17ad6c29d7395e2b66f6a8e78a9e4f0f1652cf62243e52e881e
diff --git a/app-text/cutemarked/cutemarked-0.11.1.ebuild b/app-text/cutemarked/cutemarked-0.11.1.ebuild
new file mode 100644
index 000000000000..7ce2107ae0b5
--- /dev/null
+++ b/app-text/cutemarked/cutemarked-0.11.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qmake-utils
+
+DESCRIPTION="Qt5 markdown editor"
+HOMEPAGE="https://github.com/cloose/CuteMarkEd"
+SRC_URI="https://github.com/cloose/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ app-text/discount
+ app-text/hunspell
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/CuteMarkEd-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}"-respect-destdir.patch
+}
+
+src_configure() {
+ eqmake5 ROOT="${D}" CuteMarkEd.pro
+}
diff --git a/app-text/cutemarked/files/cutemarked-0.11.1-respect-destdir.patch b/app-text/cutemarked/files/cutemarked-0.11.1-respect-destdir.patch
new file mode 100644
index 000000000000..2ce1469538f7
--- /dev/null
+++ b/app-text/cutemarked/files/cutemarked-0.11.1-respect-destdir.patch
@@ -0,0 +1,24 @@
+diff -ru CuteMarkEd-0.11.1/app/app.pro CuteMarkEd-0.11.1-sane/app/app.pro
+--- CuteMarkEd-0.11.1/app/app.pro 2015-07-06 12:02:22.000000000 +0200
++++ CuteMarkEd-0.11.1-sane/app/app.pro 2015-07-09 14:53:29.398899757 +0200
+@@ -243,7 +243,7 @@
+ ## INSTALLATION
+
+ unix {
+- isEmpty(PREFIX): PREFIX = /usr
++ isEmpty(PREFIX): PREFIX = $${ROOT}/usr
+ DATADIR = $${PREFIX}/share
+
+ # install desktop file
+diff -ru CuteMarkEd-0.11.1/fontawesomeicon/fontawesomeicon.pro CuteMarkEd-0.11.1-sane/fontawesomeicon/fontawesomeicon.pro
+--- CuteMarkEd-0.11.1/fontawesomeicon/fontawesomeicon.pro 2015-07-06 12:02:22.000000000 +0200
++++ CuteMarkEd-0.11.1-sane/fontawesomeicon/fontawesomeicon.pro 2015-07-09 14:52:45.867901697 +0200
+@@ -39,7 +39,7 @@
+
+ unix {
+ # install plugin
+- target.path = $$[QT_INSTALL_PLUGINS]/iconengines
++ target.path = $${ROOT}/$$[QT_INSTALL_PLUGINS]/iconengines
+ INSTALLS += target
+ message("The project will be installed in $$[QT_INSTALL_PLUGINS]/iconengines")
+ }
diff --git a/app-text/cutemarked/metadata.xml b/app-text/cutemarked/metadata.xml
new file mode 100644
index 000000000000..40433d25c55a
--- /dev/null
+++ b/app-text/cutemarked/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zx2c4@gentoo.org</email>
+ <name>Jason A. Donenfeld</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">cloose/cutemarked</remote-id>
+ </upstream>
+</pkgmetadata>