summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2021-01-13 22:30:37 +0700
committerAndrey Grozin <grozin@gentoo.org>2021-01-13 22:30:37 +0700
commit098516d7337a77d5ccb2060e24cccd2c4dbd6af9 (patch)
tree8210b3432c4d29ccdeca8792247e51faed600149 /app-text/pdfarranger
parentapp-emulation/containerd: fix 1.4.3 tarball (diff)
downloadgentoo-098516d7337a77d5ccb2060e24cccd2c4dbd6af9.tar.gz
gentoo-098516d7337a77d5ccb2060e24cccd2c4dbd6af9.tar.bz2
gentoo-098516d7337a77d5ccb2060e24cccd2c4dbd6af9.zip
app-text/pdfarranger: ebuild improvements
Suggested-by: Andreas Sturmlechner <asturm@gentoo.org> Closes: https://bugs.gentoo.org/764638 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'app-text/pdfarranger')
-rw-r--r--app-text/pdfarranger/pdfarranger-1.6.2.ebuild28
1 files changed, 19 insertions, 9 deletions
diff --git a/app-text/pdfarranger/pdfarranger-1.6.2.ebuild b/app-text/pdfarranger/pdfarranger-1.6.2.ebuild
index ca5563883b52..f3d0a8fa4fe9 100644
--- a/app-text/pdfarranger/pdfarranger-1.6.2.ebuild
+++ b/app-text/pdfarranger/pdfarranger-1.6.2.ebuild
@@ -1,34 +1,44 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+
+PYTHON_COMPAT=( python3_{7..9} )
DISTUTILS_USE_SETUPTOOLS=rdepend
-inherit distutils-r1 xdg-utils
+inherit distutils-r1 optfeature xdg-utils desktop
DESCRIPTION="Merge or split pdfs; rearrange, rotate, crop pages."
HOMEPAGE="https://github.com/jeromerobert/pdfarranger"
SRC_URI="https://github.com/jeromerobert/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
-RDEPEND="dev-python/pikepdf[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP},cairo]
+
+RDEPEND="
+ app-text/poppler[introspection,cairo]
+ dev-python/pikepdf[${PYTHON_USEDEP}]
dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP},cairo]
x11-libs/gtk+:3[introspection]
x11-libs/pango[introspection]
- app-text/poppler[introspection,cairo]"
+"
DEPEND="${RDEPEND}
- dev-python/python-distutils-extra[${PYTHON_USEDEP}]"
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+"
src_install() {
distutils-r1_src_install
- insinto /usr/share/icons
- doins -r data/icons/hicolor
+ for x in 16 32 48 256 scalable
+ do doicon -s ${x} data/icons/hicolor/${x}*/*
+ done
}
pkg_postinst() {
+ elog "Optional dependency:"
+ optfeature "image file import" media-gfx/img2pdf
+
xdg_desktop_database_update
xdg_icon_cache_update
xdg_mimeinfo_database_update