summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Schollmeyer <nex+b-g-o@nexadn.de>2023-01-01 22:15:48 +0100
committerArthur Zamarin <arthurzam@gentoo.org>2023-01-03 21:09:51 +0200
commite23ab2743ff80c115d892f24b1ada9ada6a4e81a (patch)
treeff5cbcb4188a9e9f467d20efddb86411c1d211ff /app-vim
parentdev-python/json5: Bump to 0.9.11 (diff)
downloadgentoo-e23ab2743ff80c115d892f24b1ada9ada6a4e81a.tar.gz
gentoo-e23ab2743ff80c115d892f24b1ada9ada6a4e81a.tar.bz2
gentoo-e23ab2743ff80c115d892f24b1ada9ada6a4e81a.zip
app-vim/lightline: update EAPI 6 -> 8, small QA and build fixes
This commit bumps to the latest EAPI and fixes the versioned build by updating the SRC_URI and setting S for non-live versions. The explicitly set src_compile() is dropped, since upstream provides no Makefile and thus the function is no-op anyway. Bug: https://bugs.gentoo.org/889198 Signed-off-by: Adrian Schollmeyer <nex+b-g-o@nexadn.de> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/lightline/lightline-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/app-vim/lightline/lightline-9999.ebuild b/app-vim/lightline/lightline-9999.ebuild
index a73386531e33..73b4c0fdc1a2 100644
--- a/app-vim/lightline/lightline-9999.ebuild
+++ b/app-vim/lightline/lightline-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit vim-plugin
@@ -9,13 +9,13 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/itchyny/lightline.vim/"
else
- SRC_URI="https://github.com/itchyny/${PN}.vim/archive/master.zip -> ${P}.zip"
+ # LIGHTLINE_COMMIT=
+ SRC_URI="https://github.com/itchyny/lightline.vim/archive/${LIGHTLINE_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}.vim-${LIGHTLINE_COMMIT}"
fi
DESCRIPTION="vim plugin: A light and configurable statusline/tabline"
HOMEPAGE="https://github.com/itchyny/lightline.vim/"
LICENSE="MIT"
VIM_PLUGIN_HELPFILES="${PN}"
-
-src_compile() { :; }