summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-01-12 19:44:29 -0700
committerTim Harder <radhermit@gentoo.org>2020-01-12 19:46:07 -0700
commite94c9af802b65f571aa2809448e898637f63fec5 (patch)
tree9b56a16f22685e83cf3159138533ec4c0c92554f /app-vim
parentdev-python/html5-parser: Remove old versions (diff)
downloadgentoo-e94c9af802b65f571aa2809448e898637f63fec5.tar.gz
gentoo-e94c9af802b65f571aa2809448e898637f63fec5.tar.bz2
gentoo-e94c9af802b65f571aa2809448e898637f63fec5.zip
app-vim/gundo: update to EAPI 7 and drop python2 support
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/gundo/files/gundo-2.6.2-python3.patch13
-rw-r--r--app-vim/gundo/gundo-2.6.2-r1.ebuild32
2 files changed, 45 insertions, 0 deletions
diff --git a/app-vim/gundo/files/gundo-2.6.2-python3.patch b/app-vim/gundo/files/gundo-2.6.2-python3.patch
new file mode 100644
index 000000000000..89b7706c8190
--- /dev/null
+++ b/app-vim/gundo/files/gundo-2.6.2-python3.patch
@@ -0,0 +1,13 @@
+Force defaulting to python3.
+
+--- sjl-gundo.vim-6918f8da3839/autoload/gundo.vim
++++ sjl-gundo.vim-6918f8da3839/autoload/gundo.vim
+@@ -44,7 +44,7 @@
+ let g:gundo_close_on_revert = 0
+ endif"}}}
+ if !exists("g:gundo_prefer_python3")"{{{
+- let g:gundo_prefer_python3 = 0
++ let g:gundo_prefer_python3 = 1
+ endif"}}}
+ if !exists("g:gundo_auto_preview")"{{{
+ let g:gundo_auto_preview = 1
diff --git a/app-vim/gundo/gundo-2.6.2-r1.ebuild b/app-vim/gundo/gundo-2.6.2-r1.ebuild
new file mode 100644
index 000000000000..3140f0d8ba4b
--- /dev/null
+++ b/app-vim/gundo/gundo-2.6.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit vim-plugin python-single-r1 vcs-snapshot
+
+DESCRIPTION="vim plugin: visualize your vim undo tree"
+HOMEPAGE="https://sjl.bitbucket.io/gundo.vim/"
+SRC_URI="https://bitbucket.org/sjl/gundo.vim/get/v${PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ || (
+ app-editors/vim[python,${PYTHON_USEDEP}]
+ app-editors/gvim[python,${PYTHON_USEDEP}]
+ )
+ ${PYTHON_DEPS}"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+PATCHES=( "${FILESDIR}"/${P}-python3.patch )
+
+src_prepare() {
+ rm -r .gitignore .hg* package.sh README* site tests || die
+ default
+}