summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/datadraw
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/datadraw')
-rw-r--r--dev-db/datadraw/Manifest1
-rw-r--r--dev-db/datadraw/datadraw-3.1.1.ebuild51
-rw-r--r--dev-db/datadraw/metadata.xml16
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-db/datadraw/Manifest b/dev-db/datadraw/Manifest
new file mode 100644
index 000000000000..5d8cca4454db
--- /dev/null
+++ b/dev-db/datadraw/Manifest
@@ -0,0 +1 @@
+DIST datadraw3.1.1.tar.gz 607914 SHA256 11186bbf37f9b5bb11d7a21bc5ce6c45496b24dfa62a064d57d3ad414f4a9c04 SHA512 64773b984cb9d6928ec486833ee03f07c6c5f21dcfcc446e21fe90eb432b7a09459ea65e24c46df70bc6b791dfc640caf16b6f6cdd8a35319969bb8ec7e65009 WHIRLPOOL e4af7bcf81cf52c1743273ca2c09de7435066fd194a0ee5235171de2876acf865db951fe432e7e0cefd34af98902a242fa9906054d4b5fe9df6b7daa890128dc
diff --git a/dev-db/datadraw/datadraw-3.1.1.ebuild b/dev-db/datadraw/datadraw-3.1.1.ebuild
new file mode 100644
index 000000000000..d5938f24b1be
--- /dev/null
+++ b/dev-db/datadraw/datadraw-3.1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="feature rich database generator for high performance C applications"
+HOMEPAGE="http://datadraw.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PN}${PV}/${PN}${PV}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/${PN}${PV}
+
+src_prepare() {
+ tc-export CC
+ sed -e "/^CFLAGS=/s:-g -Wall:${CFLAGS}:" \
+ -i configure \
+ -i dataview/configure \
+ -i util/configure || die
+
+ sed -e '/^datadraw:/,+2s:\\$(CFLAGS):\\$(CFLAGS) \\$(LDFLAGS):' \
+ -i configure || die
+}
+
+src_install() {
+ dobin ${PN}
+
+ insinto /usr/$(get_libdir)
+ for lib in util/*.a ; do
+ newins ${lib} lib$(basename ${lib})
+ done
+ insinto /usr/include
+
+ doins util/*.h
+
+ dodoc README
+ if use doc ; then
+ dodoc manual.pdf
+ dohtml -r www/index.html www/images
+ fi
+ use examples && dodoc -r examples
+}
diff --git a/dev-db/datadraw/metadata.xml b/dev-db/datadraw/metadata.xml
new file mode 100644
index 000000000000..d2893a9317a8
--- /dev/null
+++ b/dev-db/datadraw/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-electronics</herd>
+<maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+</maintainer>
+<upstream>
+ <remote-id type="sourceforge">datadraw</remote-id>
+</upstream>
+<longdescription lang="en">
+DataDraw is a feature rich database generator for high performance C applications. DataDraw gives your C application a high performance object-oriented framework at speeds that beat hand coded C.
+</longdescription>
+</pkgmetadata>
+