summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2020-07-18 05:26:31 +0000
committerPatrick Lauer <patrick@gentoo.org>2020-07-18 05:26:31 +0000
commitc363b522cb4d112b43dd97efb6f6c0ebff712ecd (patch)
tree809e687e291070d2966edfbcadbc10b955bfa748 /dev-db/repmgr/repmgr-5.1.0.ebuild
parentdev-perl/Net-DNS-SEC: Drop m68k re bug #665088 (diff)
downloadgentoo-c363b522cb4d112b43dd97efb6f6c0ebff712ecd.tar.gz
gentoo-c363b522cb4d112b43dd97efb6f6c0ebff712ecd.tar.bz2
gentoo-c363b522cb4d112b43dd97efb6f6c0ebff712ecd.zip
dev-db/repmgr: Bump
Older versions don't build with newer postgres Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-db/repmgr/repmgr-5.1.0.ebuild')
-rw-r--r--dev-db/repmgr/repmgr-5.1.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-db/repmgr/repmgr-5.1.0.ebuild b/dev-db/repmgr/repmgr-5.1.0.ebuild
new file mode 100644
index 000000000000..06a26ac1e9b5
--- /dev/null
+++ b/dev-db/repmgr/repmgr-5.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils multilib
+DESCRIPTION="PostgreSQL Replication Manager"
+HOMEPAGE="http://www.repmgr.org/"
+SRC_URI="http://www.repmgr.org/download/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND=">=dev-db/postgresql-9.3[server,static-libs]"
+RDEPEND="${DEPEND}
+ net-misc/rsync"
+
+src_compile() {
+ emake USE_PGXS=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" USE_PGXS=1 install
+ export PGSLOT="$(postgresql-config show)"
+ einfo "PGSLOT: ${PGSLOT}"
+ PGBASEDIR=/usr/$(get_libdir)/postgresql-${PGSLOT}
+ PGBINDIR=${PGBASEDIR}/bin/
+ PGCONTRIB=/usr/share/postgresql-${PGSLOT}/contrib/
+ dodir $PGCONTRIB $PGBINDIR
+ dosym $PGBINDIR/repmgr /usr/bin/repmgr${PGSLOT//.}
+ dosym $PGBINDIR/repmgrd /usr/bin/repmgrd${PGSLOT//.}
+ dodoc CREDITS HISTORY COPYRIGHT *.md
+ insinto /etc
+ newins repmgr.conf.sample repmgr.conf
+ fowners postgres:postgres /etc/repmgr.conf
+ ewarn "Remember to modify /etc/repmgr.conf"
+}