summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-dotnet/mono-zeroconf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-dotnet/mono-zeroconf')
-rw-r--r--dev-dotnet/mono-zeroconf/Manifest1
-rw-r--r--dev-dotnet/mono-zeroconf/metadata.xml5
-rw-r--r--dev-dotnet/mono-zeroconf/mono-zeroconf-0.9.0.ebuild35
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-dotnet/mono-zeroconf/Manifest b/dev-dotnet/mono-zeroconf/Manifest
new file mode 100644
index 000000000000..f06113c8dbad
--- /dev/null
+++ b/dev-dotnet/mono-zeroconf/Manifest
@@ -0,0 +1 @@
+DIST mono-zeroconf-0.9.0.tar.bz2 139677 SHA256 6bde77b0240a45b148f182677022cf20d8ee8e1711b220a1162c9fae3726d7e1 SHA512 043ecd8f5123864b000bb854db4d2e58535dcaf9306e64846f67c2d2e025d631701a5e5abdfd29ffca5a8d08bba05aabfd1633641a89ffd3c116498d80effc25 WHIRLPOOL f388051dbcc36b2713e67e4482a9793aaf1f3a42799441b3baa32b0ec5845903bf78e9e26451e11721be3c6ccdbff1fc39b666a1ca7910b32b20e5379be9567b
diff --git a/dev-dotnet/mono-zeroconf/metadata.xml b/dev-dotnet/mono-zeroconf/metadata.xml
new file mode 100644
index 000000000000..e01adbb307db
--- /dev/null
+++ b/dev-dotnet/mono-zeroconf/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+</pkgmetadata>
diff --git a/dev-dotnet/mono-zeroconf/mono-zeroconf-0.9.0.ebuild b/dev-dotnet/mono-zeroconf/mono-zeroconf-0.9.0.ebuild
new file mode 100644
index 000000000000..1065caefd250
--- /dev/null
+++ b/dev-dotnet/mono-zeroconf/mono-zeroconf-0.9.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit base mono
+
+DESCRIPTION="a cross platform Zero Configuration Networking library for Mono and .NET"
+HOMEPAGE="http://www.mono-project.com/Mono.Zeroconf"
+SRC_URI="http://banshee-project.org/files/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/mono-2.0
+ >=net-dns/avahi-0.6[mono]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf $(use_enable doc docs) --enable-avahi
+}
+
+src_compile() {
+ emake -j1 || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README || die "docs failed"
+ mono_multilib_comply
+}