summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-04-28 11:05:25 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-04-28 11:05:25 +0200
commit861d16e6e8f48edb6a176649c806b6d1460b3f0e (patch)
treef9c827e3cfca12dd03b7c0e17737361dbb568fbe /dev-java/jansi/jansi-1.11-r2.ebuild
parentdev-java/java-getopt: removed obsolete 1.0.14 (diff)
downloadgentoo-861d16e6e8f48edb6a176649c806b6d1460b3f0e.tar.gz
gentoo-861d16e6e8f48edb6a176649c806b6d1460b3f0e.tar.bz2
gentoo-861d16e6e8f48edb6a176649c806b6d1460b3f0e.zip
dev-java/jansi: switched to slot 0 + eapi7/java 1.8 in 1.11
Closes: https://bugs.gentoo.org/783906 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/jansi/jansi-1.11-r2.ebuild')
-rw-r--r--dev-java/jansi/jansi-1.11-r2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-java/jansi/jansi-1.11-r2.ebuild b/dev-java/jansi/jansi-1.11-r2.ebuild
new file mode 100644
index 000000000000..0c1149bbd7b2
--- /dev/null
+++ b/dev-java/jansi/jansi-1.11-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# TODO: Get doc (missing classpath entries) working.
+JAVA_PKG_IUSE="source test"
+
+inherit vcs-snapshot java-pkg-2 java-ant-2
+
+DESCRIPTION="A library that allows you to use ANSI escape sequences in your console output"
+HOMEPAGE="http://jansi.fusesource.org/"
+SRC_URI="https://github.com/fusesource/${PN}/archive/${PN}-project-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~ppc64 x86"
+
+CDEPEND="dev-java/jansi-native:0"
+
+DEPEND="${CDEPEND}
+ test? (
+ dev-java/ant-junit4:0
+ dev-java/junit:4
+ )
+ >=virtual/jdk-1.8:*"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.8:*"
+
+S="${WORKDIR}/${P}/jansi"
+
+EANT_GENTOO_CLASSPATH="jansi-native"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+JAVA_SRC_DIR="src/main/java"
+
+src_prepare() {
+ default
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+}
+
+EANT_TEST_GENTOO_CLASSPATH="ant-junit4,junit-4"
+
+src_test() {
+ EANT_EXTRA_ARGS="-Djunit.present=true"
+
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+
+ use source && java-pkg_dosrc src/main/java/org
+}