summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-07-30 12:26:51 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-08-14 08:35:21 +0300
commit935933cffaa5bf0f621138c23701e82982b1d541 (patch)
tree4eb48b3ba189b8be6e6fb6eb1f43d282d38b7a5e /dev-lang
parentsys-kernel/gentoo-kernel-bin: fix 5.10.55-r1 (arm64) SRC_URI (diff)
downloadgentoo-935933cffaa5bf0f621138c23701e82982b1d541.tar.gz
gentoo-935933cffaa5bf0f621138c23701e82982b1d541.tar.bz2
gentoo-935933cffaa5bf0f621138c23701e82982b1d541.zip
dev-lang/nasm: Adopt package
Also update upstream remote, bump to EAPI 8, and drop unused eclass. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Matt Smith <matt@offtopica.uk> Closes: https://github.com/gentoo/gentoo/pull/21836 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/nasm/metadata.xml11
-rw-r--r--dev-lang/nasm/nasm-2.15.05.ebuild11
2 files changed, 12 insertions, 10 deletions
diff --git a/dev-lang/nasm/metadata.xml b/dev-lang/nasm/metadata.xml
index 9d9747cb8767..86d32bc3da0e 100644
--- a/dev-lang/nasm/metadata.xml
+++ b/dev-lang/nasm/metadata.xml
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person" proxied="yes">
+ <email>matt@offtopica.uk</email>
+ <name>Matt Smith</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<longdescription>
The Netwide Assembler, NASM, is an 80x86 assembler designed for portability
and modularity. It supports a range of object file formats, including Linux
@@ -11,7 +18,7 @@ and easy to understand, similar to Intel's but less complex. It supports
Pentium, P6, MMX, 3DNow!, SSE and SSE2 opcodes, and has macro capability.
</longdescription>
<upstream>
- <remote-id type="sourceforge">nasm</remote-id>
+ <remote-id type="github">netwide-assembler/nasm</remote-id>
<bugs-to>https://bugzilla.nasm.us/</bugs-to>
</upstream>
</pkgmetadata>
diff --git a/dev-lang/nasm/nasm-2.15.05.ebuild b/dev-lang/nasm/nasm-2.15.05.ebuild
index c8a16b87337d..297cea8bba39 100644
--- a/dev-lang/nasm/nasm-2.15.05.ebuild
+++ b/dev-lang/nasm/nasm-2.15.05.ebuild
@@ -1,21 +1,18 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit flag-o-matic
-
DESCRIPTION="groovy little assembler"
HOMEPAGE="https://www.nasm.us/"
SRC_URI="https://www.nasm.us/pub/nasm/releasebuilds/${PV/_}/${P/_}.tar.xz"
+S="${WORKDIR}"/${P/_}
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="amd64 ~arm64 ~ia64 ~ppc64 x86 ~amd64-linux ~x86-linux"
IUSE="doc"
-RDEPEND=""
-DEPEND=""
# [fonts note] doc/psfonts.ph defines ordered list of font preference.
# Currently 'media-fonts/source-pro' is most preferred and is able to
# satisfy all 6 font flavours: tilt, chapter, head, etc.
@@ -30,8 +27,6 @@ BDEPEND="
)
"
-S=${WORKDIR}/${P/_}
-
PATCHES=(
"${FILESDIR}"/${PN}-2.15-bsd-cp-doc.patch
)
@@ -43,5 +38,5 @@ src_compile() {
src_install() {
default
- emake DESTDIR="${D}" install_rdf $(usex doc install_doc '')
+ emake DESTDIR="${ED}" install_rdf $(usex doc install_doc '')
}