summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2020-08-08 16:23:27 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2020-08-08 16:26:53 -0400
commit81eaaf673c0b30c7407e4261ef31290e6fbeed53 (patch)
tree68a166887c603f4f4e7d909f8f0146a2b4c85ff9 /dev-libs/libmateweather
parentmedia-sound/jamin: Fix make check failure in po/ subdir (diff)
downloadgentoo-81eaaf673c0b30c7407e4261ef31290e6fbeed53.tar.gz
gentoo-81eaaf673c0b30c7407e4261ef31290e6fbeed53.tar.bz2
gentoo-81eaaf673c0b30c7407e4261ef31290e6fbeed53.zip
dev-libs/libmateweather: Fix 736370
Bug: https://bugs.gentoo.org/736370 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'dev-libs/libmateweather')
-rw-r--r--dev-libs/libmateweather/files/libmateweather-1.24.0-fix-tzdata-hints.patch31
-rw-r--r--dev-libs/libmateweather/libmateweather-1.24.0-r1.ebuild55
2 files changed, 86 insertions, 0 deletions
diff --git a/dev-libs/libmateweather/files/libmateweather-1.24.0-fix-tzdata-hints.patch b/dev-libs/libmateweather/files/libmateweather-1.24.0-fix-tzdata-hints.patch
new file mode 100644
index 000000000000..d1c3cab11651
--- /dev/null
+++ b/dev-libs/libmateweather/files/libmateweather-1.24.0-fix-tzdata-hints.patch
@@ -0,0 +1,31 @@
+From 354086a51ea676b6575dbb3ec62d749ec0a7c607 Mon Sep 17 00:00:00 2001
+From: rbuj <robert.buj@gmail.com>
+Date: Fri, 22 May 2020 20:19:57 +0200
+Subject: [PATCH] Locations: America/Godthab was renamed to America/Nuuk
+
+---
+ data/Locations.xml.in | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/data/Locations.xml.in b/data/Locations.xml.in
+index 5488867..62529b9 100644
+--- a/data/Locations.xml.in
++++ b/data/Locations.xml.in
+@@ -6482,7 +6482,7 @@
+ -->
+ <name>Danmarkshavn</name>
+ </timezone>
+- <timezone id="America/Godthab">
++ <timezone id="America/Nuuk">
+ <!-- The primary timezone for Greenland, although sources
+ seem to point towards calling the area "Western
+ Greenland" rathern than just "Greenland".
+@@ -6502,7 +6502,7 @@
+ <name>Thule AFB</name>
+ </timezone>
+ </timezones>
+- <tz-hint>America/Godthab</tz-hint>
++ <tz-hint>America/Nuuk</tz-hint>
+ <city>
+ <!-- A city in Greenland.
+ The local name in Kalaallisut is "Uummannaq".
diff --git a/dev-libs/libmateweather/libmateweather-1.24.0-r1.ebuild b/dev-libs/libmateweather/libmateweather-1.24.0-r1.ebuild
new file mode 100644
index 000000000000..3363dc56b7d8
--- /dev/null
+++ b/dev-libs/libmateweather/libmateweather-1.24.0-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="MATE library to access weather information from online services"
+LICENSE="LGPL-2.1+ GPL-2+"
+SLOT="0"
+
+IUSE="debug"
+
+COMMON_DEPEND=">=dev-libs/glib-2.50:2
+ >=dev-libs/libxml2-2.6:2
+ >=net-libs/libsoup-2.54:2.4
+ >=sys-libs/timezone-data-2010k:0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8:*
+ >=sys-devel/libtool-2.2.6:2
+ virtual/pkgconfig:*
+"
+
+PATCHES=()
+
+src_prepare() {
+ local tz_ver=$(best_version sys-libs/timezone-data)
+ tz_ver=${tz_ver#sys-libs/timezone-data-}
+ if $(ver_test "${tz_ver}" -ge "2020a" ); then
+ PATCHES+=( "${FILESDIR}/${P}-fix-tzdata-hints.patch" )
+ fi
+ mate_src_prepare
+}
+
+src_configure() {
+ mate_src_configure \
+ --enable-locations-compression \
+ --disable-all-translations-in-one-xml \
+ --disable-icon-update
+}