summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-10-30 17:44:00 +0000
committerJoonas Niilola <juippis@gentoo.org>2024-01-11 15:26:06 +0200
commit24520d4ae8eedf7c4a8b3ee987e5b99e7de7a229 (patch)
tree16c6677a40568f77f285f9c2ad834a1fff9fe9ac /dev-libs
parentsys-process/bottom: Drop 0.9.{1,3} (diff)
downloadgentoo-24520d4ae8eedf7c4a8b3ee987e5b99e7de7a229.tar.gz
gentoo-24520d4ae8eedf7c4a8b3ee987e5b99e7de7a229.tar.bz2
gentoo-24520d4ae8eedf7c4a8b3ee987e5b99e7de7a229.zip
dev-libs/libezV24: Fix call to undeclared function fcvt
Closes: https://bugs.gentoo.org/895044 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33588 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libezV24/files/libezV24-0.1.1-clang16-build-fix.patch21
-rw-r--r--dev-libs/libezV24/libezV24-0.1.1-r3.ebuild38
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/libezV24/files/libezV24-0.1.1-clang16-build-fix.patch b/dev-libs/libezV24/files/libezV24-0.1.1-clang16-build-fix.patch
new file mode 100644
index 000000000000..6579fe476c0f
--- /dev/null
+++ b/dev-libs/libezV24/files/libezV24-0.1.1-clang16-build-fix.patch
@@ -0,0 +1,21 @@
+Bug: https://bugs.gentoo.org/895044
+--- a/ezV24.c
++++ b/ezV24.c
+@@ -42,6 +42,7 @@
+ #include <errno.h>
+ #include <termios.h>
+ #include <sys/ioctl.h>
++#include <sys/param.h>
+
+
+ #define __EZV24_C__
+--- a/snprintf.c
++++ b/snprintf.c
+@@ -61,6 +61,7 @@
+
+ /* From: Id: sprint.c,v 1.5 1995/09/10 18:35:09 chuck Exp */
+
++#define _GNU_SOURCE
+ #include <ctype.h>
+ #include <stdlib.h>
+ #include <stdarg.h>
diff --git a/dev-libs/libezV24/libezV24-0.1.1-r3.ebuild b/dev-libs/libezV24/libezV24-0.1.1-r3.ebuild
new file mode 100644
index 000000000000..eae3daeb9b04
--- /dev/null
+++ b/dev-libs/libezV24/libezV24-0.1.1-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="library that provides an easy API to Linux serial ports"
+HOMEPAGE="http://ezv24.sourceforge.net"
+SRC_URI="mirror://sourceforge/ezv24/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+HTML_DOCS=( api-html/. )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-test.patch
+ "${FILESDIR}"/${P}-clang16-build-fix.patch
+)
+
+src_prepare() {
+ default
+
+ tc-export AR CC RANLIB
+ sed -i -e 's:__LINUX__:__linux__:' *.c *.h || die
+}
+
+src_install() {
+ export NO_LDCONFIG="stupid"
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" install
+ einstalldocs
+
+ find "${ED}" -name '*.a' -delete || die
+}