summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-09 12:44:47 +0000
committerSam James <sam@gentoo.org>2021-01-09 12:44:52 +0000
commitb3a910978cea78211106831b4d694331ff67f465 (patch)
treee90073787e6a7abfcb60aed05a8f550fcf3ff413 /dev-ml/parmap
parentapp-emulation/lxc: update DESCRIPTION (diff)
downloadgentoo-b3a910978cea78211106831b4d694331ff67f465.tar.gz
gentoo-b3a910978cea78211106831b4d694331ff67f465.tar.bz2
gentoo-b3a910978cea78211106831b4d694331ff67f465.zip
dev-ml/parmap: bump to 1.2
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/parmap')
-rw-r--r--dev-ml/parmap/Manifest1
-rw-r--r--dev-ml/parmap/parmap-1.2.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/parmap/Manifest b/dev-ml/parmap/Manifest
index 5714ec1af55c..78a77aa680b5 100644
--- a/dev-ml/parmap/Manifest
+++ b/dev-ml/parmap/Manifest
@@ -1,2 +1,3 @@
DIST parmap-1.0_rc8.tar.gz 98699 BLAKE2B 755208d0b380c200c5fb2a38334bcd422ea3e3c86bd8a52db37e256dd45c22c05e8577a5f13ae14d4ad553d16c212ae2a1b299e0870ac71a52e0bf11ddf2ecc4 SHA512 96bbe49f06dc3611577e87d9e6f5ca32e10271d6a14a0970bd4548fcaf268f833b3143258e14328237a60578e2355687e4bff031a021903f3e2280ef1713cc65
DIST parmap-1.1.1.tar.gz 44311 BLAKE2B db80056b2207d0e6723486b930bd0636171e0f2d710706b5348f2f098eb866fe9ab5dc516754e70bc81641484d4403868950ed6b35abd926d3212402f91ca41f SHA512 8333337b4f58496dad7c3417449ad6ba319c84d5cdb8434772479c9bde5708af95c230c9e1a9a31e4276d88cce3d827b1655c42a110ccd889d1735fcfecf0c20
+DIST parmap-1.2.tar.gz 47083 BLAKE2B e790087273fcf749b000c7ad3a2f5b2cafea91c529e3a4687b1d882d203cb43e4069a42675319c27878d8bca3fa0e19af96ab1dfda8df3967dc48d28ec542b91 SHA512 69431e146e8aa01823ae1583c6a5e7753436cecee37c3da3064a836c20cf8c6b9033248412203406d03bd4efdd957b2e118ea5c5866e3bd1f668d8c4fd48777f
diff --git a/dev-ml/parmap/parmap-1.2.ebuild b/dev-ml/parmap/parmap-1.2.ebuild
new file mode 100644
index 000000000000..44ada0a27777
--- /dev/null
+++ b/dev-ml/parmap/parmap-1.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+MY_PV="${PV/_/-}"
+DESCRIPTION="Library to exploit multicore architectures for OCaml programs"
+HOMEPAGE="https://www.dicosmo.org/code/parmap/"
+SRC_URI="https://github.com/rdicosmo/parmap/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV/+/-}"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+BDEPEND="dev-ml/dune-configurator"
+RDEPEND=">=dev-lang/ocaml-4.03:=[ocamlopt?]"
+DEPEND="${RDEPEND}"