summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2018-10-22 20:51:07 +0200
committerSebastian Pipping <sping@gentoo.org>2018-10-22 20:51:07 +0200
commitbd5e4a1955b04f4bae2c28d4398b199daffd52ef (patch)
treebad8ec17960b112c3010780d7c01907c7e46406b /dev-python/ansi2html
parentdev-libs/appstream: Add missing dev-qt/linguist-tools:5 DEPEND (diff)
downloadgentoo-bd5e4a1955b04f4bae2c28d4398b199daffd52ef.tar.gz
gentoo-bd5e4a1955b04f4bae2c28d4398b199daffd52ef.tar.bz2
gentoo-bd5e4a1955b04f4bae2c28d4398b199daffd52ef.zip
dev-python/ansi2html: 1.5.2
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'dev-python/ansi2html')
-rw-r--r--dev-python/ansi2html/Manifest1
-rw-r--r--dev-python/ansi2html/ansi2html-1.5.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/ansi2html/Manifest b/dev-python/ansi2html/Manifest
index 8324d79b6187..a8b17e8cb5d9 100644
--- a/dev-python/ansi2html/Manifest
+++ b/dev-python/ansi2html/Manifest
@@ -3,3 +3,4 @@ DIST ansi2html-1.2.0.tar.gz 46748 BLAKE2B c5ea7d35640f93562f6098a46dbeff9248e25b
DIST ansi2html-1.3.0.tar.gz 35989 BLAKE2B b2f949e2c559b2da91d3095b4d8ac2091bd15aad46b178a01aa59d4c900917e733f6ab3884d9c4c7c46bfa530936339d9b105a0471a09eb7a01693c43e8a87dd SHA512 73d1b3431e22146c4fe18fef4b05413231d79d627c396d67528d0aa1ab07a7ef4bcfeff56829b85d9fe9ad508599b782318911f7b10d6b9a1bc98780e31389d7
DIST ansi2html-1.4.2.tar.gz 25485 BLAKE2B 93f3bbd307b916c9ca60379235600606dbe16f1b6e423d0d2615f7825e92a6d7a8469ae7d60cf5131b4c3431897b3161bfcd2a0327525a332bcd6a6980dad5c9 SHA512 29c569839788968ba5a1fed8dddd4cc92f40ca88b4135b597815012ea44a44e8b7a3c2259d2d5d5f3cc690400be882236b88c0764a649da5679431501aab0b1c
DIST ansi2html-1.5.1.tar.gz 27133 BLAKE2B 8a8017b8f4edb878b105138ec0dfe3fbde8647315382d763eeae7f90f094b60f0cb7205718c75930ccb7ca1183e40e5205eca6f8362e20445d930d92db23bc22 SHA512 367fa9721de65a6e14118d65de9ea8ede1ecc9f0809115ecccf481947aa442409ca972442e51a75bc4f14913566255142da4e411fe060dfda5e55f84a7ac67af
+DIST ansi2html-1.5.2.tar.gz 27124 BLAKE2B 0d02e8cea46622c4d2cbd06f06fd31b3c7e93d61f6b9eadb37815d2ee490b6ce4233fb019f175f61465ef89520a944bbe14543627a6421a64304b58dc038c0ca SHA512 163d5784d04e6eea0847676b967051382fa74a354c19462d1b73980fd1b0a7eb45ce1f1bd88cca803356e7767ccab1bbce6de4152c98aec98534f4ed7d65a83f
diff --git a/dev-python/ansi2html/ansi2html-1.5.2.ebuild b/dev-python/ansi2html/ansi2html-1.5.2.ebuild
new file mode 100644
index 000000000000..076a1f0115aa
--- /dev/null
+++ b/dev-python/ansi2html/ansi2html-1.5.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Convert text with ANSI color codes to HTML"
+HOMEPAGE="https://pypi.org/project/ansi2html/ https://github.com/ralphbean/ansi2html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+ )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ chmod -x "${S}"/tests/* || die
+ esetup.py check
+ esetup.py test
+}
+
+python_install_all() {
+ doman man/${PN}.1
+ DOCS=( README.rst man/${PN}.1.txt )
+ distutils-r1_python_install_all
+}