summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-19 08:05:44 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-19 10:42:46 +0100
commit90856e05c626155d075e8e96b5d342f86047e598 (patch)
treeffe3592ef59ab2049f5a5a72a4532d8012a03219 /dev-python/autocommand
parentdev-python/dask: Bump to 2022.11.1 (diff)
downloadgentoo-90856e05c626155d075e8e96b5d342f86047e598.tar.gz
gentoo-90856e05c626155d075e8e96b5d342f86047e598.tar.bz2
gentoo-90856e05c626155d075e8e96b5d342f86047e598.zip
dev-python/autocommand: Bump to 2.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/autocommand')
-rw-r--r--dev-python/autocommand/Manifest1
-rw-r--r--dev-python/autocommand/autocommand-2.2.2.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/autocommand/Manifest b/dev-python/autocommand/Manifest
index 40298bf7338c..d5b86e98df25 100644
--- a/dev-python/autocommand/Manifest
+++ b/dev-python/autocommand/Manifest
@@ -1 +1,2 @@
DIST autocommand-2.2.1_p20211118.gh.tar.gz 22093 BLAKE2B 186062c0234fc0cc553c5d2a474a5fef46e0de25de8220228715265630fc95ed5f9b64321131322af71fadcc70ef79690652cd555a908b4e8628603a8ee494b2 SHA512 488228c7536f00ff9fbed99677440bfd7228aa64189bbcfb6aad7a92dc698d8283dfbd619ffeaeef883b0e600a90e2a0f56fa79958f144ce673dff53f8d59f89
+DIST autocommand-2.2.2.gh.tar.gz 22188 BLAKE2B 757fd96d0505466e7d3e371e13e931d0dd20d9b02da3e88c2bf85b1b946ef6c67fb14366856fe66c23adab5d635c4bd08d51acc7e55830636cce5aa0a0c265bc SHA512 5ed109db16a0e309ed5107b26db0b70ed8669d73817e82eb5a219650d29f53785aa1f9471b2ac71d21dbffc9f0a13ea0fdf69e63ab534fd84407a1d6741cf5b5
diff --git a/dev-python/autocommand/autocommand-2.2.2.ebuild b/dev-python/autocommand/autocommand-2.2.2.ebuild
new file mode 100644
index 000000000000..6cae5f6f33a5
--- /dev/null
+++ b/dev-python/autocommand/autocommand-2.2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to create a command-line program from a function"
+HOMEPAGE="
+ https://github.com/Lucretiel/autocommand/
+ https://pypi.org/project/autocommand/
+"
+SRC_URI="
+ https://github.com/Lucretiel/autocommand/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest