summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-04 05:58:03 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-04 05:58:03 +0100
commitdd5cfb99530ae7c2cea7750c277bf260f927ea93 (patch)
tree3043b927be8ad82478106041a821aeb63fa519d7 /dev-python/botocore
parentdev-python/QtPy: Bump to 1.11.3 (diff)
downloadgentoo-dd5cfb99530ae7c2cea7750c277bf260f927ea93.tar.gz
gentoo-dd5cfb99530ae7c2cea7750c277bf260f927ea93.tar.bz2
gentoo-dd5cfb99530ae7c2cea7750c277bf260f927ea93.zip
dev-python/botocore: Bump to 1.23.20
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.23.20.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 03136029e5a1..893dff39293c 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,4 +4,5 @@ DIST botocore-1.23.15.tar.gz 8499971 BLAKE2B d08fdcb398cd6bcb63a8922ebfb0f1c32c6
DIST botocore-1.23.17.tar.gz 8604819 BLAKE2B f6be48e3d0a2397be4934d9adaddbc4f2d70b2b002585e3057aead69ba934f4e53fcbffe7ea3f5919aa85d1cefe8c1abf6d1e150af6a18bd96561901d1ba7f87 SHA512 fecbb2f2ac451ffc97d7d8ad8224c3d1eff81fa225839199f403be9428cea203c077beb7c05e412784d8b6bedace3c1f24ca45730cc7877961931ac14912d1e1
DIST botocore-1.23.18.tar.gz 8647407 BLAKE2B a1c5a9006d0e2214ad1fc89752043832e657a2bb1994b9b91981430d6544818d79d669cbdf8e41b4cd6880dfb6bf001dfc03e9616da4873a89b0c3f8fcd3fdc5 SHA512 65ec3aad0508dc9a4d0426658b5a0dfec011613d236248726f94e128c2b762ac652fd5078973a9a7a101cb1a01c3dadc52b272a584310cf76ca798884c06f25b
DIST botocore-1.23.19.tar.gz 8666566 BLAKE2B 617704ba2bb367f864a6b493be9b643e52f8c22041d255252aae5e21c684544db1d58fc06f920e20ddfa54b8a3c166627d046b79d6ef06db2cd034fb58397258 SHA512 6a551cd50ecbad954982a7e6296c803a20d28065df04c9ca482b91aa91b6f336df8f81fd706771c0f04d55e2f3803cc4f1ec9b347e490e492515df427f52a692
+DIST botocore-1.23.20.tar.gz 8668630 BLAKE2B 3b6b65dd73886bf05ec52fd8e2a3d139f29b56019647f66191578d46dd68bb6c71136632cc6576d8fad84f931990c929e30135e74e9f2125bef14b1cfddd35e4 SHA512 f60df34af21a1d2f8c0d85352404ada5c83eb2bf9190fbe2b9f371c02e95bd23fc2b1e9e857a66057f93af62d1c30b908fc343a1505ad1cca0f245a94026ea17
DIST botocore-1.23.5.tar.gz 8374467 BLAKE2B 467092e7d8aa5ccb756132669049865445a47205913964c1c944b20caaf100b1efdd1bf3af9c5416ff079b487e6d4d08ffe6208e2b352d09655cc5be21c88739 SHA512 6afca19b724f9019f21e5993ce970d605b95d31c1a4e969ec1b4080510a5a120b3fa0cfd5ade973a9203bd6b7983a3dbca2f7a03108a9167392efd60d5e2fe9b
diff --git a/dev-python/botocore/botocore-1.23.20.ebuild b/dev-python/botocore/botocore-1.23.20.ebuild
new file mode 100644
index 000000000000..80a198d56414
--- /dev/null
+++ b/dev-python/botocore/botocore-1.23.20.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ distutils_install_for_testing --via-venv
+ epytest tests/{functional,unit}
+}