summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-03 21:03:27 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-03 21:55:53 +0200
commit7ff833e61ec6daea6dc3d97bf850aab4b39a7c9e (patch)
tree6649caba23ab4323628451af0a805f2f6bb71301 /dev-python/cattrs
parentdev-util/cvise: Bump to 2.6.0 (diff)
downloadgentoo-7ff833e61ec6daea6dc3d97bf850aab4b39a7c9e.tar.gz
gentoo-7ff833e61ec6daea6dc3d97bf850aab4b39a7c9e.tar.bz2
gentoo-7ff833e61ec6daea6dc3d97bf850aab4b39a7c9e.zip
dev-python/cattrs: Bump to 22.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cattrs')
-rw-r--r--dev-python/cattrs/Manifest1
-rw-r--r--dev-python/cattrs/cattrs-22.2.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/cattrs/Manifest b/dev-python/cattrs/Manifest
index 4c2e996470cf..6f2ed5507bd7 100644
--- a/dev-python/cattrs/Manifest
+++ b/dev-python/cattrs/Manifest
@@ -1 +1,2 @@
DIST cattrs-22.1.0.gh.tar.gz 108033 BLAKE2B 823e3ab466fd73385a4aaefb547b3457ee9cd100f38b6778c26bbe3d93e23ed9a00f071d6a5d7626da91e6660e2a8118e70cfa53a5960d550b9038fffec58eef SHA512 db1effb8d632dc3843d38b18bcd439c35d8bae0e4379b075417eaedbc130f6426186c0d299bc5b5d68a7354d7c5e53927ba5e0e989d498841a73237c588febb8
+DIST cattrs-22.2.0.gh.tar.gz 117001 BLAKE2B 34601cf48c582da2d9aa8d741a08919b5f06043bc6ba6b072d8b0934e90e781349b1325ced478ca0b42b50db1f7fe2a6d3cd16ac29609efd72c9aa894debfe9e SHA512 d198864402f56d4e9403c61ee3d9d109c5eac3350908afa1e244dbe31e4bc986271fcb4c72bde9cdaa9ee865c6a8b81de68ec0d51490ed658b410714e1fc550c
diff --git a/dev-python/cattrs/cattrs-22.2.0.ebuild b/dev-python/cattrs/cattrs-22.2.0.ebuild
new file mode 100644
index 000000000000..6737972d47f6
--- /dev/null
+++ b/dev-python/cattrs/cattrs-22.2.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Composable complex class support for attrs and dataclasses"
+HOMEPAGE="
+ https://pypi.org/project/cattrs/
+ https://github.com/python-attrs/cattrs/
+"
+SRC_URI="
+ https://github.com/python-attrs/cattrs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-20.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-6.54.5[${PYTHON_USEDEP}]
+ >=dev-python/immutables-0.18[${PYTHON_USEDEP}]
+ )
+"
+# test_preconf:
+# dev-python/bson[${PYTHON_USEDEP}]
+# dev-python/msgpack[${PYTHON_USEDEP}]
+# dev-python/orjson[${PYTHON_USEDEP}]
+# dev-python/pyyaml[${PYTHON_USEDEP}]
+# dev-python/tomlkit[${PYTHON_USEDEP}]
+# dev-python/ujson[${PYTHON_USEDEP}]
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e 's:--benchmark.*::' \
+ -e '/addopts/d' \
+ -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # unpackaged deps, see above
+ epytest tests --ignore tests/test_preconf.py
+}